Gateway EUI from ID

I’m registering a new outdoor gateway using the legacy packet forwarder.

My gateway ID is cxl_garage_gateway_alpha, but when I paste it into the gateway ID field when registering a gateway, the EUI byte size is too small.

I have also added 0000 to the start of the ID, and the EUI is again too small in byte size. How do I get the correct EUI?

Following this guide for setting up.

Are you pasting cxl_garage_gateway_alpha? The EUI should be a HEX string, not an alpha numeric string.

I’m pasting and then ticking the legacy packet forwarder box to convert it. How do I convert it to a HEX string and type that out?

That’s a bit of a novel approach for inventing an EUI.

If you really wanted to go that way:

echo -en "cxl_garage_gateway_alpha" | xxd -g 1
00000000: 63 78 6c 5f 67 61 72 61 67 65 5f 67 61 74 65 77  cxl_garage_gatew
00000010: 61 79 5f 61 6c 70 68 61                          ay_alpha

And trim/expand the digits.

But there’s a recommended way to make an EUI from an Ethernet/WiFi MAC that probably makes more sense. An EUI is an identifier, not a name.

1 Like

Perfect, thank you - I also ended up looking for an online alphanumeric to hex converter and going from there. I appreciate the suggestion; is the full EUI from your comment supposed to be 63 78 6c 5f 67 61 72 61 67 65 5f 67 61 74 65 77 61 79 5f 61 6c 70 68 61, or the first 8 bytes of that only?

I registered a gateway with the EUI 63 78 6C 5F 67 61 72 61, but it has shown up as “not connected.” I’m not sure at this point if it is a wrong EUI or another issue.

That’s the one you made up yourself. Isn’t the one from the following screenshot that I copied from the manual you linked to a hexadecimal one already?

image

Next, from the same instructions:

Connecting to the The Things Network Backend

  1. To connect this gateway to the The Things Network console, register the gateway using the I’m using the Legacy Packet Forwarder option.
  2. The EUI of the gateway can be derived from the Gateway ID which can be found in the ODE GUI, under Packet Forward > Module 1 Settings. Add 0000 at the beginning of the Gateway ID to get the Gateway EUI. For example 80029c10xxxx becomes 000080029c10xxxx.
  3. This is the value to be entered in the Gateway ID field on the console.
2 Likes

You could read the instructions you linked to… check @arjanvanb s message…

I’ve been having trouble getting to the ODU GUI page that you took a screenshot of, and that’s included in the guide we’ve been discussing. When I type the gateway’s IP address into the web browser, I get the following page:
image

From there I find the local wifi I use on my laptop and save the information. Is there another way to access the ODU GUI that I’m missing? Would be great to find that page with the hexadecimal already there for me.

Edit: If you’re curious, hitting ‘advanced options’ shows the account server (thethingsnetwork.org) and the gateway key, which I don’t think(?) is helpful in registering a gateway.

Cheers

I’d say you’re looking at the setup page of an indoor Kickstarter The Things Gateway. So, I’d assume you’ve got the wrong IP address or host name, typically http://things-gateway.local/ for the Kickstarter The Things Gateway. (Or you’re using the wrong setup guide.)

Proceed with care, don’t just randomly try things: it’s easy to lose ownership of the TTIG (or any gateway) in TTN Console.

1 Like

I think you’re right, I am also working with an indoor gateway that is quite successful. I got this latest outdoor one from industries to have a more robust version with hopefully a longer range.

I’m currently looking through our router’s connected (online & offline) devices and am not seeing it. I’ll do some digging to see how to get the router to see the gateway and respond with any updates within the work day. Thank you for the advice so far

Success! Thank you all for the advice, the gateway showed up under the router connected devices, as did the ODU GUI, and just finished up the setup guide. It is now connected on TTN.

For people troubleshooting in the future - I went back to my hardware setup and the PoE input cable (between the router and the ‘data in’ port) had slipped out; always the small things.

Thank you all again