Gateway keeps rapidly flaishing green

So, I reset my gateway and connected everything according to the guide. Now the gateway keeps rapidly flashing green. And when I use the TTN console my node connects with a different gateway far away after some time. In TTN the gateway shows offline no traffic is passing. It is connected to wifi but not operating correctly what could be the problem?

Gateway: TBMH100 indoor

Which console did you set it up in?

In the The Things Network console. We first used it in TTI-console had a problem with a 5 minute timeout for device class C and wanted to test if it was the same on TTN-console.

Which version?

V2, I think of the TTN-console if that is what you mean.

TTN v2 doesn’t support Class C

TTN v3 doesn’t support TTIG yet

So, I have to use TTI for Class C with TTIG?

That would seem to be the only combination left - if you are getting a TTI instance you can ask the sales desk staff for the details.

So, I tried switching back to TTI. But the led keeps blinking rapidly green. Looks like it can’t connect to the LNS. I’ve searched the forum, the problems been known before but have not found a fix. Turning it on and off a couple of times could fix it, but hasn’t worked as of yet. Any ideas?

To clarify, what do you mean when you say TTI?

Is this the paid service?