Gateway only forwards packets if connected to mobile data

Hello, I have a RAK7246 gateway but it does not send packets if it is connected to my home’s router. I am sure that it is connected to the internet because I was able to ping it from my laptop. However, the nodes won’t connect via OTAA. The gateway used to work fine before but now it only works when I connect it to my mobile data. I tried to change my router’s DNS to Google DNS and even reset it multiple times. Any suggestions on how to fix this?

Have you checked the latency back into the internet?

1 Like

Also check if your ISP is blocking some ports - not unknown for ISP’s to block e.g. port 1700 used for UDP PF - sometimes changing policy in same network/segment - works one month off the next - if so complain and tell them its not their job to sensor the internet! :wink: (Some use excuse that ports may be used for PC sharing software - often used by nefarious types to phish/hi-jack users PC’s so they claim its for ‘their users protection’!.. (VM in UK were regular offenders in UK a few years back…)

1 Like

First thing is to get into a shell on the box, via a serial UART or ssh or similar.

Then some of what you want to check is if you can ping out to things on the Internet, eg does

ping let you bounce a packet off google’s DNS server?

If not, you may want to do ifconfig (might in some setups need sudo) to see what address your active interfaces have

And then route -n to make sure that the one that’s actually active is listed as a route to everything ( and with an appropriate IP gateway, and has the lowest metric.

Sometimes multiple network setups leave you trying to route all traffic through an interface that’s no longer active, either because it’s the only global route entered, or has a lower metric than the one that is active.

1 Like

Here are 3 good place to ping to, to see your latency, as TTN is deployed on AWS.

1 Like

Hey everyone thanks for replying!

I tried to ping as cslorabox suggested and so far there was no problem with it. I also tried to ping the websites Johan_Scheepers, and again there was no problem with the ping. However, my gateway still forwards packets if it is only connected to my mobile data. Your replies gave me an idea for a temporary fix. I turned on my mobile hotspot in my laptop to allow the gateway to connect to it. Once connected, I turned on my VPN (Kaspersky) and allowed sharing. This seemed to work fine for me, hopefully, others who have the same problem can see this too. With this, I think that Jeff-UK was on point regarding my ISP blocking some ports. I live in the Philippines so it is very likely to happen.

Thank you all for your help

1 Like