Getting "failed to start the concentrator" on Raspberry Pi/iC880A/India 865Mhz gateway

Hope you all doing well. I need some help from your side and its about The GATEWAY (RASBERRY-PI 3B+ along with IC880A).
I am using this gateway for INDIAN frequency IN-865-867 and try to access through PUTTY.
But, PUTTY shows “Failed To Start the Concentrator”.
Can you tell me why this is happened with me or what are the reason behind this. Below I provided image of it.

Have you checked that the IC880 gets 5Volt? Most of the time I had these problems the voltage was too low.

Yes Sir, i already did it.

SPI is configured in raspi-config?

Yes sir.

Is your Pi connected via WiFi (wlan0), but the gateway using the mac address of the fixed ethernet (eth0)?
Could you perhaps post the global_conf.json and local_conf.json?

Sir, I am using ETHERNET cable for INTERNET connection.
i am using sudo nano local_conf.json”

Hi @sacchidanand_utech, are you using the correct reset pin?

The start of my /opt/ttn-gateway/bin/ script is:

$ more /opt/ttn-gateway/bin/
#! /bin/bash

# Reset iC880a PIN
echo "$SX1301_RESET_BCM_PIN"  > /sys/class/gpio/export
echo "out" > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN/direction
echo "0"   > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN/value
sleep 0.1
echo "1"   > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN/value
sleep 0.1
echo "0"   > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN/value
sleep 0.1
echo "$SX1301_RESET_BCM_PIN"  > /sys/class/gpio/unexport

This is typically a result of:

  • incorrect SPI wiring
  • overly long SPI wiring (including the ground)
  • incorrect SX1301 reset wiring
  • failure to drive the chosen SX1301 reset GPIO
  • excessive SPI clock speed (especially if you were using on the of the newer RAK concentrators, less likely to be an issue with an iC880, but still trying 1 or 2 MHz isn’t a bad idea)

Thank you sir for the reply.
Yes sir, I am using correct RESET pin.

Thank you sir,
I ll check all the parameters that you provided in your message and convey you as soon as possible.

I have slowed down the SPI_SPEED to 5MHz, and also mapped the gps to tty10, as the serial10 port is giving trouble to open for GPS synchronization. But still when i run the python file to start the concentrator, it still gives an error, “failed to start the concentrator”. Can there be any issues, I am not looking at.
My setup is an iC880A with 1 SX1301 and 2 sx1255 connected to a raspberry pi 3b+.
I use the indian frequency of 865Mhz.
Is there any way to check the connection of gps and whether my concentrator is successfully resetting?

Once the software starts and is able to start the concentrator you will be able to see if the GPS works correctly. The GPS not working will not result in a failure to start the software, just messages in the log.

Go way down to 1MHz for SPI to check. And where do you set the speed? In the correct file and do you recompile after changing it?
Which PCB do you use to connect the iC880A to the RPi?

I have tried all the combinations, 8MHz, 5MHz as well as 1Mhz.

The file home/pi/lora_gateway/libloragw/src/loragw_spi_native.c

how do you do that?

I have used a custom built iC880A lora shield concentrator, which has its connections made directly to the RPi 3b+.

Custom as in your own design? In that case you should know which RPi pin you connected the iC880A shield reset pin to. If not you own design, where did you get it?

Do you rebuild (recompile) the software after changing that file?

go to what on your system seems to be home/pi/lora_gateway/libloragw and type make

then go to the packet forwarder directory next to it and type make again.

If at all possible get a scope and look at the signals, both for speed and integrity even in the sense of being connected through at all.

yes, it is my own design and the 22nd pin of the RPi is connected to the resent pin, i.e., GPIO25 and the concentrator is now being reset.

Does rebuildind the software mean using the make -s command. Then yes I have done that.