Getting started with the P-NUCLEO-LRWAN2 V1.3.1 problem

I connected my gateway and node device, I get the join request and join accept messages and then I get an uplink message.When I power off the node device and connect it again, join request and join accept messages are returned, so there is no uplink.Uplink message arrives after 8 hours on average.Shouldn’t it be connected immediately? or how can i solve it?

NODE software :STM32CubeExpansion_LRWAN_V1.3.1 (AT_Master software)

It’s not normal to turn off a device as it will forget where it got to with various sequence counters.

However to allow us to do this whilst testing, we can turn off the Frame Counter checks which will likely be your problem - when you turn the device back on, it starts sending at 1, which takes many more sends before it gets to the last number the server received, only then will it be accepting the uplinks.

See ABP node stopped working -> Fixed by creating new ABP.. Why? :) - the quick win is to reset frame counters on the device overview page or to just turn them off on the settings page.

thank you so much i will try


How can i reset received and transmitted messages ?

For gateways you can not.

1 Like

I didn’t mean reset the gateway counters, I mean’t the device in your application.

I understand you
I’m just curious :slight_smile:

Why can’t I get an uplink message?

Looks like the device is struggling to join

yes…at_master software works fine but end_node software not working :confused:

Try an ABP uplink for simplicity?

I tried didn’t work

What led you to believe it didn’t work - any output from the module or nothing on the gateway.

As far as I can recall, you unpack the software, load it up in something like MDK or CubeIDE, change commissioning.h to have your details, compile & download.

I use CubeIDE.
Change commissioning.h. and hw_conf.h
I tried the 1.2.1 software again it didn’t work

Didn’t work as NOTHING happened - no debug output - no blinkenlights?

I’m debugging.Actually, static void LoRaMacHandleIrqEvents( void )
enters TxTimeout inside.

Is there a problem with the usi module (WM-SG-SM-42) on the node version?

If it is, then the whole design is flawed - maybe you have one that is not in spec or has some damage?

at_master software working.I will write to the st community
thank you