Globalsat LS-113P

Has anyone had any success getting an LS-113P to work on TTN? I have a Laird gateway and Laird Sentrius temperature and humidity sensor up an running on TTN. I just received a LS-113P with little to know documentation. It appears to power up but will not register on the network. Status remains as “never seen” on the console.

I have not managed yet, looking at the serial output it seems quite happy sending LoRa data, but where to ???

I got the serial port working on the LS-113P and used ATT2 JoinMode=1, AAT2 AppEui=xxxxxxxx, AAT2 AppKey=yyyyyyy, AAT1 Save and AAT1 Reset to put it into OTAA mode, set the App Eui and App Key, save the changes and reset. The serial port is now showing:

Send join request
Send join request
Send join request

Any ideas?

I don’t have one but I’m just spitballing some ideas here after looking at the AT Commands sheet I looked at here:

First off does the device work in ABP mode as expected? Secondly is ADR enabled, and lastly what is the Rx Frequency and DR set at? I’m sure there might be other things but I thought maybe if I throw out some ideas something might come up.

1 Like

Got the same CO2 111P.

It’s easy to configure it using any USB-UART adapter.

You can connect to holes on the PCB or make a custom USB-UART-USB adapter.
PCB UART config connector (57600, 8N1)

1 +3.3V
2 TX
3 RX

Hint is that Globalsat uses microUSB jack in nonstandard way.
Instead of D+, D- wires thay mapped it as Rx, Tx.
Thus I connected to my UART adapter male USB connector with corresponding pins.
VCC 5v, Rx, Tx, Gnd.

And please remember to use CRLF as a line feed.
If you use Linux or MacOSX use following to remap CR to CRLF

picocom --omap crcrlf -b57600 /dev/cu.usbserial


Does anyone know if the Spread level can be changed for the LS-111p?

By default it’s sending once per minute on SF12, if I remember this would result in < 20 messages allowed by TTN per day - rendering it useless.

I’m not sure how ADR is working or if I can see these messages in the TTN console but it’s enabled and doesn’t seem to work…

Also, fixed values of SF11 or SF12 are not allowed (though that’s not currently enforced.)

I can only set ADR in these devices and the interval. However, the GW is in the same room and it still sends with “data_rate”: “SF12BW125”,

See its documentation. You’ll see downlinks in the gateway’s Traffic page in TTN Console; do you see any? If so, then maybe the device does not process (or receive) the downlink.

Like documented, scheduling a downlink might speed up the process, but as TTN might need as many as 20 uplinks that might still need you to wait a day before scheduling that. If TTN decides it’s urgent, scheduling a downlink earlier is not needed as TTN will then create its own downlink anyhow. Also, US915 and AU915 should get an initial ADR downlink right after joining, when ADR is enabled. Clicking each uplink in TTN Console might show details about ADR too.

Thank you, I did not see any ADR messages yet, however, I’m unsure how to recognize them. Where do I see the ADR bit in the GW console?

To see the ADR bit in each uplink you can use an online decoder for the full LoRaWAN uplink packet as seen in the gateway’s Traffic page.

Decoding the ADR MAC command in the downlink might need some manual work; see an example for AU915 in LMIC Library Always Does Unwanted Downlink.

Thank you @arjanvanb I will give it a try this week.

Regarding this device, does anyone spot a setting that I’m missing in the config besides enabling ADR?
I’m not sure if it needs something else such as confirmation for ADR downlink messages? Although this would probably be against the limits again.

I did not get an answer yet from Globalsat.

AAT2 Tx_Channel looks like the way to set your channel list and the datarate for each channel. That should let you get your spreading factor down to something that reduces your airtime, such as 7.

Right now it reports:
Freq.869525000 ,DR0

Do you maybe know what DR0 to 15 means? How does it affect the spreading factor?

1 Like

Thank you, I just found a page explaining it!

On any other setting other than DR0 the client log shows “JOIN_NOT_ACCEPT” and it keeps sending join requests.

Anyone got an idea what could be wrong? Maybe a setting is missing and TTN does not accept it?
I see a join accept in the GW console though:

Did you manage to get this resolved? Having the same issue here.

new record ! :partying_face: first post in 4 years … :laughing:

can you describe your issue

I have a Globalsat LS-112 which I’ve tried to connect. I’ll share my experiences.

Was able to connect using ABP. You’ll need the AT command set: AAT2 NwkSKey=?, AAT2 AppSKey=?, AAT2 DevAddr=?, AAT2 DevEui=? to extract the values set in the firmware. There are default values for these but depending on where you bought the device, it may not be set to the default.

Part of the problem you’ll have when connecting Globalsat devices to “The Things Network” is that some of Globalsat’s hardware appears to be hardwired to communicate using Sub-Band 1 (902.3 - 903.7 MHz). The Things Network expects to communicate using Sub-Band 2 (903.9 - 905.3).

I could find no AT COMMAND in of the reference documents found using Google which mentions how to change the Sub-Band on this device.

Using the AT command: “AAT2 Tx_Channel=8,903900000,30,1,0” was able to transmit on channel 8 but after the transmission the “…1,0” gets changed to “…0,0” and the device won’t using the channel again unless the “AAT2…” command is executed again, and again, etc. It is the second to the end digit being a 1 which allows the device to use that channel. I did preform “ATT1 Save” & “ATT1 Reset” after changing the 0 to a 1. The ‘1’ only persists until the first transmission, after that the ‘1’ changes back to a ‘0’, the channels stops being used.

Unless either the secret AT command for changing the Sub-Band to #2 or The Things Network changes their entire network to used Sub-Band #1. There is no way to guarantee Globalsat can be configured to work the way you want.

I’ve includes the AT commands used to change the board to use Sub-Band 2 and turn off Sub-Band 1, To save you the time in working out the details.

This change only worked for 8 transmissions. After the 8, the 1 in the second to last field were switched back to 0 by the device.

Good luck.

AAT2 Tx_Channel=8,903900000,30,1,0
AAT2 Tx_Channel=9,904100000,30,1,0
AAT2 Tx_Channel=10,904300000,30,1,0
AAT2 Tx_Channel=11,904500000,30,1,0
AAT2 Tx_Channel=12,904700000,30,1,0
AAT2 Tx_Channel=13,904900000,30,1,0
AAT2 Tx_Channel=14,905100000,30,1,0
AAT2 Tx_Channel=15,905300000,30,1,0

AAT1 Save
AAT1 Reset

AAT2 Tx_Channel8=?
AAT2 Tx_Channel9=?
AAT2 Tx_Channel10=?
AAT2 Tx_Channel11=?
AAT2 Tx_Channel12=?
AAT2 Tx_Channel13=?
AAT2 Tx_Channel14=?
AAT2 Tx_Channel15=?

AAT2 Tx_Channel=0,902300000,30,0,0
AAT2 Tx_Channel=1,902500000,30,0,0
AAT2 Tx_Channel=2,902700000,30,0,0
AAT2 Tx_Channel=3,902900000,30,0,0
AAT2 Tx_Channel=4,903100000,30,0,0
AAT2 Tx_Channel=5,903300000,30,0,0
AAT2 Tx_Channel=6,903500000,30,0,0
AAT2 Tx_Channel=7,903700000,30,0,0

AAT1 Save
AAT1 Reset

AAT2 Tx_Channel0=?
AAT2 Tx_Channel1=?
AAT2 Tx_Channel2=?
AAT2 Tx_Channel3=?
AAT2 Tx_Channel4=?
AAT2 Tx_Channel5=?
AAT2 Tx_Channel6=?
AAT2 Tx_Channel7=?