GW deleted now GW register failing msg already exists

I need some help.
After 3 to 4 years I wanted to reactivate my RAK2245 Pi HAT, EUI is B827EBFFFE4FF04E . The old GW was no longer present in TTN console view. So I created a new one. Creation was ok. Require authenticated connection was not checked but GW was disabled all time.
So I updated the firmware of RAK2245 from version 2.9.1R to 4.2.5R. SSH-communication with PuTTy is working normal. But disconnect status remained.
So I deleted the GW as I planned to create a new GW with the same device.
When I now try to create I get error message “already exist”.
Seems deleting was a big mistake. But what can I do?

you need to read the error message carefully to see just what ‘already exists’ then use forum search for solution - this is a regular query. Note GW EUI =/= GW ID :wink:

It seems to be a very common pattern for people just to try to delete everything and try again.

There is a warning telling you that you can’t re-use the gateway-id, right?
If so, are people just next-next-next clicking through it and ignoring the warning? And why?

Should the warning be made even more obvious / harder-to-ignore?
Perhaps offer an ‘RESET EVERYTHING ABOUT THIS GATEWAY’ button? So people try that first, before the delete-recreate attempt.
Provide a canned-link like ?
Or even disallow deletion of gateways (e.g. don’t allow deletion within one week of creation)?

Yep, but that in itself isnt such a big issue - used to be a case of dont delete GW - ever! but more relaxed and flexible these days :slight_smile:

The problems arise 1) what happens next/when re-registering, 2) people do not read (and understand) what error messsage actually says - sometime its human nature that we read and see what we think it should say, 3) Lack of self help and reading/learning of documentation, 4) some folks ask 1st (a typical trait these days with people expecting instant answers and ‘free’ tech support, and only then do their research :wink: 6) People jump in before reading up… (classic RTFM…)

We could ask TTI Core to plaster stuff all over the site but that way lies chaos and clutter, and even then experience shows people will still ‘dodge’/ignore warnings and caveats (thinks old maps - here be dragons! :rofl: ), so no; more isnt alway needed or even helpful…people just need to engage with what is already provided.

On the registration page there is advice/info and links to documentation - if users ignore not much you can do about it. In this case: (GW registration process):-
All key items have a query button.

In the case of GW ID it tells user


And provides helpfull links such as (Read More):

Where it tells more even saying wrt uniqueness and deleted entities:


The problem isnt stopping people deleting - potentially a necessary evil, but rather getting people to understand implictions and follow up especially when then re-registering

Would be disasterous and a productivity killer when recovering from say a ‘fat-finger’ incident where incorrect data used accidentally (been there worn the T-Shirt! :slight_smile: ) Need be able to immediately recover and re-instate, clients wont wait a week just 'cause someone entered the wrong data. Delete and retry is then entirely legitimate or where passing on to a new owner etc.

Where there might be scope for improvement is the TTS system ‘helpfully’ offers a GW EUI derived GW ID at time of registration - as I have commeneted on other threads for some that may be useful and easy option but I find a cryptic GW ID based on a random set of EUI characters less than helpful in managing my or other peoples fleets of GW’s - others have said the same…far better to over-type with human friendly & hopefully more useful info I feel. Problem comes when device is deleted and original ID based on EUI then gets repeated at time of re-registration leading to the error message usually called out - where users can’t be bothered to ‘be creative’ per the help tip. One improvement might be to have LNS backend recognise at time of re-registration that the EUI-based GW ID has already been used and simply not offer it and instead prompt user to over type and ‘get creative’! But am reluctant to burden the TTI Core team with a request for such a software fix when problem is a meatware/new or inexperienced user problem vs a real software or architectural problem…

First of all: thanks for spending so much time to answer my call for help.
My situation is,

  • my age is 81, consequently my brain is slowing down,
  • English is not my native language, I learned in school 65 years ago
    – so it takes time to read and understand advice/info/documentation especially when slang is used in blogs,
  • the RAK2245 Pi HAT Quick Start Guide is little different at the TTN Console picture
  • I tried to find out my failure for 2 days before asking for help,
  • actually the GW is registered but still disconnected
  • I went through (thru) the troubleshooting advises again and again with no success
  • my router indicates no error message
  • playing around with LoRaWAN is just a hobby for me and the GW is not primarily for my use but to improve the situation for the community

Certainly it is my failure and certainly I will fix it some day. But why not asking for help when it is offered?

This isn’t aimed at you personally and your bullet points are very useful in the constant quest to figure out a way to help - so thank you. Although going forward, don’t sweat it out for two days, but do use forum & documentation search - there are many many exact matches on the exact error message on the forum!

Overall there are many many good points above, but given the frequency that this comes up, I’ll relay a request for further explanation and as @Jeff-UK is our resident “it’s not the EUI, it’s the ID!” answerer, perhaps he could create one that we can link to as suggested by @bertrik so we can quickly knock such posts on the head.

the solution maybe not that when a gateway gets deleted all records are deleted of it?

more time get spent asking this question than fixing the db

there are 100’s of gateways show on the api that have been delete

maybe i am over simplifying it???

Just let me make clear that my point was not to blame anyone personally for running into this problem. It’s apparently just very common to run into it and I was thinking out loud about possible solutions.

1 Like

The main issue in my case was GW disconncted all time. Deleting GW made the case worst but thanks @Jeffs-UK info GW EUI =/= GW registering was sucessful.
But the disconnect status remained.
I found out that in the Raspberry Pi data set
the server_address was coded “”
After changing to “” GW is connected.
Updating RAK2245 to actual version 4.2.5R did not solve the failure.
Thanks all for help, topic can be closed

Ah looks like you hadn’t fully transitioned the GW firmware/config build to reflect the TTN/TTS(CE) V2 to V3 transition (from Dec 20)… Firmware update is a firmware update and would not have changed final server configuration which is a user task…still all’s well that ends well :slight_smile: Enjoy!

As I am new and just registered it seems I cannot create a new post/topic. Therefore I write here. I have the same problem. I deleted my gateway and not realized, that I cannot add the gateway anymore. Now I tried to add it again and obviously this not worked. I not found any instructions to change the ID on my gateway, which is a WisGate Edge Lite 2. I read in this forum about this problem, but I did not found a solution beside that somebody (manually) deletes the gateway EUI inside TTN. Is somebody able to help me?

Only you, as all the information is above!!

If you re-read the thread you will see that EUI is NOT the ID which is the item that can’t be duplicated - there are screen shots above that even highlight this.

Plus forum search of the error message will reveal countless other explanations.

This isn’t a help desk but please click any response that covers the solution - most likely your own!

Yes, because it’s more about how the database works - if you read the docs you’ll see what the constraints are and the reasons behind it.

Thank you very much, I now realized how it works and it worked for me!


sorry please educate me i have read this entire doc cant see the reasons behind it

can you please point the section out

EUI & ID constraints

Its underlined in “red” in my extract from the referenced document/section in my post above…

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.