Hardware reset RN2483 on things uno


(Erik van Luijk) #1

Recently I was experimenting with a Launchpad and a RN2483 pictail board. Due to my powersupply configuration the RN2483 did not respond on the serial lines until I pulled the reset line to 0V. I assume RN2483 can stay in reset if the powersupply was rising too slowly or is unstable.

On things uno the 3.3V powersupply can also power external circuitry causing unwanted behavior on the RN2483.
Perhaps a hardware reset is a nice to have feature on the things uno boards. The implementation is a little tricky without extra components. I think a FET should pull the /RESET pin of the RN2483 to 0V. Evt. this reset feature could be selected using a jumper.


#2

Can you reproduce the error situation? If so, could you try sending a break (or just set TX output to zero level for a second) and send 0x55 immediately afterwards?
I'm curious if the 'wake from sleep' sequence could resolve this.


#3

I seem to be experiencing the same with the RN2483 pictail board. I only use the USB connection, I do get a serial port in Windows but no communication. I understand the default setting for the serial port is 57600 baud. I'm using putty, there seems to be a control sequence for break but it doesn't seem to work (btw: 0x55 = ascii char 'U' ?).

What would be the easiest way of pulling the reset pin. I didn't find any description of (or reference to) the PICtail pin's in the user guide. If there is any generic document about the PICtail interfaces?


Microchip RN2483 PICTail daughter board serial comms problems
(Erik van Luijk) #4

I tried to send a break and a 0x55 char, but no communication with the RN2483 afterwards (verified with a scope)

@Batilan
Here you find the user guide of the pictail board:
http://ww1.microchip.com/downloads/en/DeviceDoc/50002366A.pdf

In order to communicate with the board on the pictail rx/tx lines the board must NOT be powered from USB. Otherwise the usb->serial converter on the pictail asserts the RX line (of the RN2483).


#5

Did you upgrade the firmware of the module or is it the original firmware?


#6

Hi Erik,

Thx for the reply, that was indeed the document where I tried to find the info (seemed most logical indeed). Thanks to Jac I found out that the information is actually in the RN2483 datasheet.

I tried to reset the module by connecting pin 1 (reset) shortly to pin 28 (gnd) (pictail interface). This seemed to work because I got a response in my terminal window: "RN2483 0.9.5 Mar 24 2015 14:15:33", so I do actually get a response from the RN2483 via the USB-Serial. Also when I type characters I see the RX LED blinking, so my keystrokes do make it to the board also.

This however didn't get me a working module: I would expect when I type a command like "sys reset" the characters would be echoed back and the RN2483 would be reset? I also tried sending break-U to trigger the auto baud feature, but nothing much seems to happen.

Also tried the tip from Jac by pulling TX (pin 21) down and sending a U (0x55 right?) right after that to no avail. (Realterm did show "nul", so that was probably a reset. So what am I overlooking / what's the secret of this nice little module?


#7

@Batilan The module does not echo any characters and it requires '\r\n' (CR LF) at the end of a line. Without \r\n it will not show any output.

PuTTY will not work, use a terminal program like termite, TerraTerm or Coolterm with settings: 57600bps, 8n1, no flow control, echo on, set options to include CR+LF


#8

OK, Thx. Indeed I found out in the mean time that communication was OK as I tried to update the firmware and saw that the update program was communicating with the module OK :blush:

Thanks to the video mentioned in the TTN UNO topic I knew I had to be patient, but in the end the update succeeded after about 6 tries. Now looking at a shiny RN2483 1.0.0 :smile:

@kersing Thx again


#9

found some info
- http://www.disk91.com/2015/technology/networks/first-step-in-lora-land-microchip-rn2483-test/


(Junting Zhu) #10

Hi @Batilan, could you please help me with the firmware update problem? I just got the things UNO board yesterday. How to connect RN2483 directly to the PC USB port?

Many thanks.


#11

I think the Things UNO can’t host the Sodaq Like firmware updater (flash space too short), so you’re right you need another board to update firmware and I don’t think you can do it connecting UNO Board to USB to a computer.

If you have any Arduino Zero, ESP8266 or ESP32 board somewhere you can try the forked firmware updater there that is working with other Arduino Zero, ESP8266 or ESP32 boards.

Of course, the board you will use for upgradding need to be 3.3V (not 5V) powered. And you need to connect 4 or 5 pins from your board (Zero or ESP)

3V3
GND
RN2483 TX 
RN2483 RX
Option RN2483 reset

You can also power your upgrade board with 3.3V from things Uno board, no problem.

Let me know if it works