Has anyone successfully deployed a new gateway and device to V3?

To be clear: devices that can join through a V2 gateway are able to send packets through a V3 gateway, but a brand-new device added to V3 seems unable to join successfully.

I am running into numerous problems trying to migrate to V3. It appears that a device registered originally through V2 can in some cases operate through a V3 gateway, but I am (so far) unable to set up a new gateway on V3, create a new device on V3, and get it to successfully join and uplink data. The constant warning messages that V2 is going away tells me not to waste any more time adding devices and gateways to V2, but V3 does not seem to work (in practice) yet. I have used both the TTOG on V3 with this problem as well as RAK (Raspberry Pi) gateways and neither work.

Please, if anyone has gotten a brand-new V3 deployment to work, please share what gateway(s) and end node(s) you have used. While we still have several months left before everything shuts down, we are now told that new device and gateway registrations are being suspended on V2, so by the end of this month I won’t be able to add any new devices because V3 never sends a join-accept.

Short answer to your quesion is Yes there are thousands of GW’s connected to V3


And thousands (10’s thousands?) devices using those GW’s

To help you, you need to help us!

There are probably >40-50 GW’s & base GW types used in the main, and many DIY variants, there are literally thousands of possible node base designs, using various MCU’s MCPu’s or commercial full products that could be used, with dozens of chip down, SIP or Module based LoRaWAN implementations drawing off dozens of proprietary stacks or dozens of LoRaWAN libraries and forks thereof…

Be precice, what HW are you using, which s/w/lbraries/dev environments, which GW images, which manufacturer? Off the shelf or DIY? ABP or OTAA join, etc etc,etc…what have you tried, what has failed, how error shown? What have you logged? What traffic or errors are you seeing in the console…have you set correct Rx windows if DIY nodes, etc?

Come back with something substantive and I’m sure there are many who will step in and assist/guide where they can and will share experience and work arounds to problems. Problem is they are not mind readers :wink:

Inspired by the passive-aggressive binary nature of the topic title:

Yes thanks, it’s all good, have a nice day :grin:

1 Like

30 days ago, move my gateway rak2245/Pi from v2 to v3 along with 7 custom nodes atmega328p Lmic, all works great :wink:

To be clear: I’ve added new gateways to V3 (MikroTik, RPi based ones using MP forwarder, Dragino, Laird, MultiTech) and new devices (Heltec Capsule, Generic Node, Dragino LDS01 [requires addtional setting to keep working with joins file, search forum for solution]) and others.
V3 works fine for all of them.

As @Jeff-UK already mentioned: you need to provide lots more detail for anyone to be able to help.

1 Like

Thanks to those who provided helpful information, I should have some options here to start from a known-good solution and work from there. I’ve shut down the old equipment for now and started with a completely new device platform with (so far) better results.

For others who may have the same problem, also refer to the helpful feedback I’ve gotten in this (somewhat related) thread. While I don’t have a complete solution, it appears that MAC v1.0.3 is more reliable than v1.0.2, despite the devices working well for me on V2 that way.

I avoided asking a very specific question about one single combination of gateway and end-node hardware precisely because the answer to my general question would help restore my faith in V3 in general without debugging a specific set of hardware. Based on the feedback here, green-field deployment of V3 should work without any problems, so I’ll revisit the specifics and if needed, ask specific questions about the particular gateway and end nodes I’m developing with.

I’m considering this issue closed for now, but I am curious about the following, if any of you care to elaborate:

@kersing: Thank you - I will try some of the device brands you mentioned. Can you confirm that when you successfully added new devices to V3 that there was absolutely no communication with a V2 gateway, which in my case allowed devices to join, and then forward through V3?

@descartes: (Same question: Can you confirm that when you successfully added new devices to V3 that there was absolutely no communication with a V2 gateway, which in my case allowed devices to join, and then forward through V3?) but what hardware have you used (you didn’t list any)? In green-field deployments, without a V2 gateway to fall back on, the answer doesn’t seem quite as clear.

@Jeff-UK: I appreciate the graph of connected gateways, but being connected versus actually allowing a device to join V3 without the presence of V2 infrastructure are a little bit different questions.

All: you might understand the skepticism from those of us in countries with few or no V2 gateways in range of our devices. In high-gateway countries, it’s likely that anyone testing a new V3 deployment would also be in range of a V2 gateway, therefore hiding this type of problem (if it ever existed).

@Raccoon: That’s exactly the kind of information that helps me, thank you, though if the devices were already registered on V2, and migrated to V3, the situation is a little different. Thank you very much for your helpful comment with a combination of hardware that worked for you.

No I can’t but I can’t see what the issue is here, I can see traffic arriving on both the v2 & v3 gateways in the office and over time I’ve done various tests with just one or the other active for a few minutes at a time since December and quite a lot in January when the TTS CE was released. I can turn the v2 gateway off now that v3 forwards to v2.

But overall, I can confirm you are being overly cautious - how do you think TTI would get on if no one could deploy at v3 gateway and devices??? You know this stack has had active use for over a year now? Why don’t you drive to a spot out of range of v2 gateways and try it yourself.

As for my kit list, again, irrelevant, they are all highly compliant products that work as per the LoRaWAN specification, again, how would TTI survive if they wrote a stack that wasn’t compliant, particularly as they are angling after getting the stack certified.

But as it happens I have RAK, Murata, Microchip, STM, PyCom, Arduino plus MCU+RFM95+LMIC devices and gateways from RAK, Dragino, M2M-Tele, MicroTik and two TTIGs.

@Jeff-UK describes me as the TTS Third Party Tester …

Fundamentally, go and try it - quicker and more reassuring. Even in the UK I can find a few hills to hide behind out of range of anything at all.

@descartes: Thank you, that’s exactly what I did (tried it and it didn’t work - duplicate packets without a Join Accept, occasional uplinks but no downlinks, and many other problems). I tried it and had many problems and was simply looking for reassurance that someone somewhere had made this work, after I tried many combinations that did not, expecting that migration to V3 would have been smoother.

Devices that worked well on V2 have not worked well on V3. That’s why I was asking for feedback to see if anyone else had tried a “green field” deployment without a V2 gateway in range, because I’ve had problems. In the end I scrapped the modules and firmware that worked on V2 and started over fresh with a completely different module and firmware on V3, and after a lot of trial and error, have one working combination that works on V3.

Side note for you @descartes:
As for your comment on the title being passive-aggressive, the constant pestering messages on the page that V2 is being shut down at the end of the year doesn’t help, particularly when TTIG still doesn’t seem to be supported. That urgency to shut down V2, when a large number of indoor gateways are still not functional on V3, combined with the policy that new gateway registrations on V2 are being discontinued, results in a great deal of frustration on the part of those of us in the community who want to support TTN. We’re trying to help grow the ecosystem, we set up gateways and pay for them, and their power, and their Internet connections, and push our clients and associates to use LoRaWAN, yet we end up looking bad when TTN forces the migration timeline without a clear migration path for many devices (because they break when you move them to V3). I hope this helps you understand the frustration that some of us feel. Please help us all pull together to build this global community – we don’t need flippant responses that lack empathy. A simple “no, we’ve never tried that” would have let me know that this use case had not been exercised yet.

For the benefit of others who might have similar trouble building their infrastructure from scratch, the working combination is a Seeed LoRa-E5-HF with a RAK Pi gateway, using MAC version 1.0.3. I also have a TTOG outdoor gateway on the roof with a high-gain omnidirectional antenna that covers several kilometers in every direction. Many other combinations of hardware, software, and settings have produced mixed (some spotty but mostly non-working) results.

Six months after TTI make TTS CE available to all and your post title implies it doesn’t work at all. That’s deeply insulting to TTI who provide a service for free to someone who has “client’s and associates” and could therefore consider if they should be using the paid for service. The development of the v3 stack has been written & presented about for almost three years now, so the transfer to v3 was inevitable. As for being pestered, you’re not, no emails, no phone calls, just a clear message on the console.

I created at test plan for the devices & gateways I have in common use to try out various combinations. There is no need to find a v3 only area, just looking at the gateway console & logs tells you that v3 devices work just fine with v3 gateways.

As for the nature of community, we don’t see you around these parts much - but you want to tap in to this community for answers.

As per:


In contrast you’ve still not told us anything about your test regime, any of the results or, until now, given us any hint about which devices you have.

This may be true for you, but as others have attested to above, just you.

As per a previous reply, I’ve a fair amount of kit I can use to test, I create code for forum users a couple (or more times a week) and try out some hardware combos as well. As well as creating commercial solutions, I create low cost devices using ATmega + RFM95 using LMIC.

So if you do care to share, we can dig in to the detail and get you going.

That is strange because my results are totally different. Only a few devices fail to work due to known firmware issues. In the cases where I find issues I try to find details (in cases where sources are available try to debug) and work with the vendors to resolve them.
And yes, I tested with and without V2 gateways in range. For some deployments there is no V2 to be seen for over 30 kilometers.

@kersing: Your response:

yes, I tested with and without V2 gateways in range

Is exactly what I was asking for. Thank you!

@descartes: I appreciate that you wanted all the details about what exactly I was doing, but I didn’t ask for anyone to solve my problems, but simply to point me to a known working solution that I can use to solve my own problem (by comparing results). Thank you for the offer of help, but I’m quite happy to develop and find my own way without needing someone else to fix my every misstep. I just wanted a “known working” system, and it took many tries with many combinations of settings to find one that works. Remember, those of us on the Community Edition are not leeches, but also provide gateways that expand the reach of TheThingsNetwork, so the arrangement is mutually beneficial. Thank you for your comments and insights.

For everyone else who weighed in on the issue, thank you, just knowing I am not alone in making this transition was comforting. Now that I have a working solution, I’m finding myself much more impressed by the well-thought-out infrastructure provided by the V3 network. Bulk importing is very functional and effective. I hope to continue to build out support for LoRaWAN in various areas of the USA where it is far less widespread than it is in the EU, and very glad to be part of a healthy and growing ecosystem.

1 Like

"Has anyone successfully deployed a new gateway and device to V3?"

For what its worth, I’ve managed to upgrade my kickstarter gateway from V2 to V3 but not yet my RAK/R.PI gateway.

Sadly no devices converted to V3 so far, Just don’t have the time to personally invest in learning how to do so atm. I hope to rectify that later.

I wish there was a sticky with links on how to do this. After all V2 to V3 is such a seismic change for everyone. Maybe there is but I didn’t find it, other than the current warning message sticky :frowning:
To be clear, I’m talking about what you have to do with end device types e.g. what to do with a setup of an arduino with RN2483

Can you repost your query regarding the setup of an RN2483 so we don’t dilute your technical needs with opinions on how unsuccessful or not others have been with migration.