Help with Axioma W1 Water Meter and Tektelic Kona Macro Gateway

Is your gateway showing traffic?

Note - it may not be showing on the web console as connected or ‘seen’ - follow the sticky link at the top of the forum for other ways to check.

Does your gateway hear the Axioma’s transmissions?

Their website has no links I could see for the tool that you refer to or much in the way of any actual setup documentation so without being able to review this sort of material, things are going to be hard to debug. Do you have links for these?

I have similar problems with axioma meters have you solved them ?


I am enclosing a documentation on the decoding of the payload of these meters. I also have the program for the infra-red configuration in local, I will send it to you if it interests you.
Axioma Lora Payload W1 V01.8 Extended.pdf (542.1 KB)



Thanks for the docs.
My question is more related to water meter and how to register them in ttn.
Problem 1 which APPEUI and key youvuse ? The one generated in ttn or the one saved in the device ?

If the one in ttn how can i save it in the device with W1 software i cannot understand how ? Write all ?

When i register the device i see in ttn that the device tramission arrive (flash yellow icon) but it is not confirmed ?

Why do i have this ? Too far from gateway ?

Best regs gp

Upon delivery of the water meters, we received a file with the AppEui and AppKey of each device. From what I know only the PC version of W1 Tools allows to change the parameters of the counter with an IR adapter to clip on the box of the counter.
Attached is the documentation

Instructions for Successful Lora Connection.pdf (3.4 MB) Instructions for Test mode.pdf (49.8 KB) Instructions on activating radio signal.pdf (1.5 MB)


For proper debugging (and searching this forum), you’ll need to get to know the proper terminology (geheimtipp: hover your mouse over an icon to see its name) and be explicit about where you see things. What you’re seeing is either the OTAA Join Request (the yellow/orange icon if seen in the gateway’s Traffic page) or the OTAA Activation (same icon, if seen in the application/device’s Data page). And I assume that for “not confirmed” you mean you don’t see a green icon for the OTAA Join Accept? (If shown, then that’s only shown in the gateway’s Traffic page.)

See some debugging steps in OTAA activation fails - is this caused by distance?, Can I use TTN without my own gateway if one is nearby? and OTAA no Join Accept after changing batteries.

Thanks i will need to do some check based on your doc.

after some trials to initialize lora I could not get completed the procedure …
btw OTAA is enabled
I put in the meter parameter even the Network and APPs key …
maybe I am to far from gateway? any idea ?

Like described in the other posts I linked to:

As your screenshot shows Activations in the application/device’s Data page you know that the settings are okay, and that TTN has accepted the device’s OTAA Join Request, assigned it a new DevAddr, and will have delegated sending an OTAA Join Accept to one of the gateway(s) that received the Join Request. As your device repeats the Join Request, it seems it did not receive the Join Accepts. That’s all we can tell.

Maybe the Join Accept arrived at the gateway too late (network latency) to be sent. Maybe the device’s timing is not okay. Maybe it’s out of reach for the downlink. Maybe the device is actually too close to the gateway.

(Aside: the details you redacted in your screenshot are not secret.)

Hi, do you know where I can get the W1 tool software and also the optical device for configuration.


Can I get a Decoder for the axioma w1, please support me if anybody getting the data till TTN??

Axioma also provided us with an excel file with all the keys, pre-programmed into the meters. As soon as 10 litres of water pass through the meter, it will do an OTAA join.

We had one meter that was mis-configured (by the factory) which had its keys set to all 00’s. We used the windows tool and an IR eye to set the correct keys, after which the meter did an OTAA join successfully.

Hi, can you tell me where you got the IR eye and the W1 tool. I have tried to contact Axioma with no success.

@jpmeijers I successfully added all the meters to TTN with OTAA but i’m struggling with getting the data in TTN. how you are reading the end data??
what about the decoder ?? please share me if you have one.

Hej @JpMeijers,

please could you help me with Axioma W1? i see the packets but in not recognize the device. What are the settings for TTS? i have the same problem as @bellarybharath had. I have the IR eye and the tool and got the keys from it but the data is not passed to TTS created device. getting: “no device matches uplink”

  • Moderator move to appropriate category.


Can you send my the W1 tool please,

I tried to reach axioma, but no response.

please send it to

Thank you so much.

I successfully got the qalcosonic W1 working on V3.

I got a copy of the tool from a guy at Axioma so I don’t know if it is copywrite so can’t send it to you.

The technical support contact I managed to get hold of was

Maybe he can help again, he was very useful to me.

These are rhe instructions he gave

- connect the optical head to your PC and place it on the meter, then find out which virtual COM port was created,

- start the tool, enter the port number, click on „Wake up meter“

- If this is done successfully – click on „Enter Test mode“ (this gives write access to the meter configuration)

- Click on „Read All“

- Go to „Radio Tab“

- Uncheck wMBus T1 box, and check Lora WAN box

- Go to “Main Settings”, and click on “Write All”. You may need to wake up the meter again, before writing new settings, because the optical interface goes to sleep state very quickly.

- Go to “Radio” tab, and click on “Activate radio”

- Go to main settings, and click on “Enter User mode”.

You may also check the LoRa WAN Tab – what data is displayed there.

1 Like


what LoraWan Version do you use?

What Gateway (manufacturer) do you use?



The lorawan version is 1.0.2 I believe
The gateway is a Dragino LPS8

Hope this helps

Hello. Our company started assembling AXIOMA meters. But we can’t get to the SW from being able to change Mbus addresses. Can you advise me on how to connect to it or how it works?