Heltec CubeCell - part 1

I am using LS14500 mainly to power esp8266 or esp32 for my nodes. I do not tested using cubecell yet, but I plan to test it soon. Looking for recommendation regarding proper setup/configuration/connecting to CubeCell. I am really satisfied with the battery performance with my existing projects… Measured battery output is approx. 3.4V at 100mA.

Thanks for the update, interesting although not cheap.

I had looked at them for very low temperature use, thats where the voltage performance suffers.

@LoRaTracker - I am using it mainly nodes which are placed under the ground, so there is no such low temperature (-3 was the lowest temp, so I do not challenge such an issue).

That was exactly the reason why I did not include 3.6V Lithium Thionyl Chloride batteries in above overview (and I have no personal experience with these batteries).

A sufficiently large capacitor as buffer could help to stabilize input voltage for short periods between deep sleeps.

The next issue to solve would be to which power input pin to connect it.

When connecting directly to the 3.3V pin:

  • The 3.6V of the battery is too high for this (max supply voltage VDD of the CubeCell module is 3.5V). A series diode would probably cause a too high voltage drop (especially under load).

    Or just connect it without series diode but that would run the CubeCell module (and connected sensors) (a bit) out of spec. This could work fine but can also cause degrading issues on longer (or shorter) term.

When connecting to Vin:

  • Vin is parallel to Vusb (5V) which is error prone and may cause damage when a USB cable is connected. Using a series diode for protection is not an option here because it will cause a too large voltage drop. Vin is input to a 3.3V voltage regulator of which VDD 3.3V is the output so voltage would drop twice when using a series diode.

So what would be the best choice?

During Wifi transmissions ESP8266 (ESP32 is probably similar) can have peaks of 200+ mA which will require use of a sufficiently large capacitor as buffer.

I have tested cube cell with TTIG indoor Gateway and join problems.
Can some report else such problems?
@wasn do you have also such problems? Is it the indoor gateway or my node?
What can I throw away?

@MOS-FET i have several CubeCell devices running andu havenNo more problems than with other nodes.
Most times the problems is that the TTN servers are not sending the accept fast enough.

I can see those join accept problems only when using TTN, when i use our own chirpstack servers these problems dont accure.

@wasn Join not accepted by node
Could it that the library is waiting to short time for join a acceptance?

@MOS-FET Stop asking the same questions in different threads! Join not accepted by node

You were asked for information in the linked post and to do a test and observe the results but you did not and instead repeat your question here. Stop wasting others’ time if you don’t want to follow provided suggestions and don’t want to provide requested details.

@bluejedi do you really think it same question? No it is not the same question! Here I asked only especially for the cubecell library and not gerally for join accaptance process. It just linked the post together

Unfortunately a lot of Heltec’s CubeCell ASR650x Arduino Core and how they have implemented the LoRaMac-node library is still unclear because not documented.

So there is no magic answer to your question. You will have to perform tests yourself and provide us with information yourself. If that is asked too much then don’t bother others with your questions.

If you start asking in this thread if join related problems can be caused by the library, it might be wise to first provide the information that you were asked for in above linked thread and continue there, because that is EXACTLY what this is about. So better provide useful information and don’t spread related questions over the forum (discussion closed).

Hi, there, sorry for the late response, you guys may know that because of the coronavirus problem, we just back to office this week, but our factory and some cooperation factories still not back to work normally… many works have to delay :rofl:

Yes, @wasn is right, as far as our test, maybe because of the net work in China main land, we also can’t get downlink messages from TTN.

Can it because of the limit of downlink messages?

Join problem mostly because of the listening frequency not matching the sending frequency.

If you can paste your gateway’s global_conf.json file, we can help you analysis the reason.

Is this document make sense to you?

I’m sure the sub-band working fine in our test.

Yep tried that with no effect, Bruce’s solution works, I’ll just use that for now

Maybe this operation make sense to you:

I have a CubeCell dev board (HTCC-AB01) running a simple test.
It transmits a fixed 3-byte uplink message (without any further processing) and the RGB LED is enabled so the LED lights with each uplink message.

So far it has sent more than 72000 uplink messages on a single battery charge already.

A 1200mAh LiPo battery is used as power source (true capacity is probably more like 1000mAh).
The CubeCell board has sent 72000+ uplink messages already on a single battery charge (and running). Battery voltage is still 3.69V so maybe 100k messages on a single charge will be possible.
(For this test battery voltage is measured manually, and not measured automatically by the node).

I lost track of the exact uplink message count and later noticed the battery was empty.
Based on my last counter check (80+k) and some extrapolation:
A total of between 90k and 100k uplink messages have been sent on a single battery charge. :+1:

1 Like

Below information is from GitHub - HelTecAutomation/CubeCell-Arduino: Heltec CubeCell Series (based on ASR6501, ASR6502 chip) Arduino support.

The currently supported ASR650x chip product models are:

MCU Relative boards
ASR6501 CubeCell-Board, CubeCell-Module, CubeCell-Cupsule
ASR6502 Coming soon


  • What is the difference between ASR6501 and ASR6502?
  • What Heltec products will use the ASR6502?


Full PDF is there.

EByte sells ASR6501 (sample) modules as low as 2+ USD per one piece delivered (depending on frequency band).
Since ASR6501 has only 1 UART access available - this SiP has little or no use for my purpose.

1 Like

I noticed (but did not see such low price).
No generic Arduino support is available for ASR650x I guess. I have only seen Arduino support for the CubeCells.

If not Arduino, what SDK/toolchain would you use for ASR650x?