How can I delete my end device

device
ı wrote 127.0.0.1 . but ı cant changing.

Open the end device (click on the eui you have listed), then in center of screen select general settings for the device (not the general settings for the application on left!) scroll down and delete end device will be shown in red text to right of save! :slight_smile:

I can’t choose because it’s faded

devi
devic

Not sure what you are trying to show - the ‘red’ text isnt bright full hue but lower contrast and I can see it above (4 o’clock relative to your arrow) - have you tried it? click/select that (does mouse pointer change from pointer to grab hand when you hover over it?)

devicess

save
you try

in general settings. I wrote 127.0.0.1 to try something. then I can’t click on the device, it’s grayed out. I hope I can explain.

Hi jeff. Add a device and save the network server address as 127.0.0.1. Then try to delete it and see if you can delete it.

Sorry no time for that - you did it (twice!) so no point me cluttering my console views too! :wink: Have you tried editing the address info in your screenshot above and using “save” to save the edit or is that not possible? Also did you try what I asked and hovered over/clicked the red “Delete end device” icon/text - what happened?

save is not possible. As I said, since I wrote 127.0.0.1 to the server address, the device does not delete. On the console, the device is dimmed, it says other cluster. tank you jeff .

In that case I suggest you post in the TTN Slack #support channel with link to this thread and ask if TTI core team can assist as it is likley beyond the scope of the Forum constributors and volunteers - maybe there is a command line interface option to delete that target end device - @descartes Nick any suggestions if this cant be done direct from console?

There are CLI commands for deleting but I’m loathed to setup a test for this instance. No reason it shouldn’t work.

1 Like

C:\lorawan-stack-cli_3.17.1_windows_amd64>ttn-lw-cli end-device delete my-honda-gps eui-70b3d57ed004b7f1
WARN Registered Network Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
WARN Registered Application Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
WARN Registered Join Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
error:cmd/ttn-lw-cli/commands:end_device_server_address_mismatch (Network/Application/Join Server address mismatch)
correlation_id=84fe26095ed843cdb89c2227d02e2611

C:\lorawan-stack-cli_3.17.1_windows_amd64>

.ttn-lw-cli.yml file

base:
config:
log:
format: console
level: info
experimental:
features:
credentials-id: eu1.cloud.thethings.network
input-format: json
output-format: json
allow-unknown-hosts: false
oauth-server-address: The Things Network Account
identity-server-grpc-address: eu1.cloud.thethings.network:8884
gateway-server-enabled: true
gateway-server-grpc-address: eu1.cloud.thethings.network:8884
network-server-enabled: true
network-server-grpc-address: eu1.cloud.thethings.network:8884
application-server-enabled: true
application-server-grpc-address: eu1.cloud.thethings.network:8884
join-server-enabled: true
join-server-grpc-address: eu1.cloud.thethings.network:8884
device-template-converter-grpc-address: eu1.cloud.thethings.network:8884
device-claiming-server-grpc-address: eu1.cloud.thethings.network:8884
qr-code-generator-grpc-address: eu1.cloud.thethings.network:8884
packet-broker-agent-grpc-address: eu1.cloud.thethings.network:8884
insecure: false
ca: “”
dump-requests: false
skip-version-check: false

PS C:\ttn> .\ttn-lw-cli config
–allow-unknown-hosts=“false”
–application-server-enabled=“true”
–application-server-grpc-address=“eu1.cloud.thethings.network:8884”
–ca=""
–config=“C:\ttn/.ttn-lw-cli.yml,C:\Users\MR.YAVAŞ/.ttn-lw-cli.yml,C:\Users\MR.YAVAŞ\AppData\Roaming/.ttn-lw-cli.yml”
–credentials-id=“eu1.cloud.thethings.network”
–device-claiming-server-grpc-address=“eu1.cloud.thethings.network:8884”
–device-template-converter-grpc-address=“eu1.cloud.thethings.network:8884”
–dump-requests=“false”
–experimental.features=""
–gateway-server-enabled=“true”
–gateway-server-grpc-address=“eu1.cloud.thethings.network:8884”
–identity-server-grpc-address=“eu1.cloud.thethings.network:8884”
–input-format=“json”
–insecure=“false”
–join-server-enabled=“true”
–join-server-grpc-address=“eu1.cloud.thethings.network:8884”
–log.format=“console”
–log.level=“info”
–network-server-enabled=“true”
–network-server-grpc-address=“eu1.cloud.thethings.network:8884”
–oauth-server-address=“The Things Network Account
–output-format=“json”
–packet-broker-agent-grpc-address=“eu1.cloud.thethings.network:8884”
–qr-code-generator-grpc-address=“eu1.cloud.thethings.network:8884”
–skip-version-check=“false”
PS C:\ttn>

PS C:\ttn> .\ttn-lw-cli end-device delete my-honda-gps eui-70b3d57ed004b7f1
WARN Registered Network Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
WARN Registered Application Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
WARN Registered Join Server address does not match CLI configuration {“configured”: “eu1.cloud.thethings.network”, “registered”: “127.0.0.1”}
error:cmd/ttn-lw-cli/commands:end_device_server_address_mismatch (Network/Application/Join Server address mismatch)
correlation_id=ae3f6c5febce480882ba89284d94a4b9
PS C:\ttn>

C:\ttn>ttn-lw-cli end-device delete my-honda-gps eui-70b3d57ed004b7f1
WARN [core]grpc: addrConn.createTransport failed to connect to {127.0.0.1:8884 127.0.0.1:8884 0 }. Err: connection error: desc = “transport: error while dialing: dial tcp 127.0.0.1:8884: connectex: The connection could not be established because the target machine actively refused.”. Reconnecting…
connection error: desc = “transport: error while dialing: dial tcp 127.0.0.1:8884: connectex: The connection could not be established because the target machine actively refused.”

I still can’t solve the problem. if i can change the network address to eu1.cloud.thethings.network the problem will be solved. but I’m writing the cli code, it doesn’t count. where am i doing wrong?

As previously noted

1 Like