How to Factory Reset Kerlink IoT?


#1

Hi,

I’ve just tried updating the office Kerlink IoT to the TTN firmware, but since then I can’t access it anymore. I first tried updating it by just plugging in the USB stick with the TTN settings, but that didn’t work. I then proceeded to use the reset procedure as described in FAQ - Kerlink Gateway. Since that moment, I can’t access the Kerlink anymore. I’ve tried both SSH and the normal web interface, but nothing works. Any tips or tricks? I do see the gateway in my router’s DHCP list, and I can ping, but connections to port 22 (SFTP and SSH) are instantly refused, and the web interface doesn’t connect either.

Thanks in advance!
Job

EDIT: Maybe someone with a WIRGRID Debug tool in Eindhoven area?

Could it be possible to issue the ‘fw_setenv bootfail 100’ and ‘reboot’ commands by ‘updating the firmware’ (that is, making a produsb.sh file on a clean USB, and having it run those two lines while the Kerlink tries to ‘update’? (I don’t want to screw the gateway up even more, so asking before trying)


Kerlink - remote password reset - Firmware upgrade / update
#2

Hi,

Have you been able to fix this problem? It would help me a lot.

Thank you!


#3

Hi,

I have contacted our Kerlink Gateway supplier (MCS) and they supplied me with the proper firmware to completely re-flash the gateway.

The process I used:

  1. Download the proper firmware from https://www.dropbox.com/s/66ckvf9imm8j9wa/Kerlink%20TTN.zip?dl=0
  2. Take the contents of the ‘TTN step 1’ directory, and copy them to the root directory of a USB stick
  3. Place the USB stick in the Kerlink
  4. Wait for at least 10 minutes. The Kerlink should now have updated itself. If this didn’t happen, follow FAQ - Kerlink Gateway to reset the gateway (with the USB stick still attached).
  5. After waiting and/or resetting (and more waiting after that), remove the USB stick and check if a ‘produsb.log’ file has emerged on the USB drive. If not, retry step 4 with more waiting, if yes, be happy.
  6. Now remove all files from the USB, and copy the contents of ‘TTN step 2’ into the USB
  7. Now, once again, stick the USB in the gateway and wait for a bit, now, the TTN settings should automatically be loaded.

Good luck, and please let me know if you run into any problems!


#4

I think it’s something you could add to the wiki since others will probably need to do it one day as the network grows.


#5

Hello again Afstkla,

Step 4 didn’t work and the problem is that I can’t factory reset my station (LoRa IoT Station 868, Wirnet Station 868).

  • If you have the WIRGRID debug-tool you still have acces. Try to solve
    the problem. No succes? Enter the following commands for factory
    reset.
    fw_setenv bootfail 100
    reboot
  • If you don’t have the WIRGRID debug-tool you can force the Kerlink into Factory Reset mode.
    Power on the system
    Press and release the reset buton
    Wait between 4 and 10 seconds.
    Repeat point 2. and 3. 22 times!

I have tried both options with no results, is there some other way to factory reset the station?

Thanks for your answer.


(Andrey) #6

Hi
I have same problem :frowning: .
Could you reload firmware? Unfortunaly, your link in item 1 doesn’t work…


(Lsantos) #7

Dear all,

I executed The update firmware procedure (Wirnet 3.1) on my LoRa IoT Station 915 and I lost SSH access to the device.

how can I proceed with to factory reset that I do not have the WIRGRID debug tool?

Best regards

Leandro Santos


(Yoshimatsu) #8

does someone can upload the proper firmware again?
the link above is broken

@Afstkla ??

Thanks a lot