How to install the things stack v3 ubuntu server

Hello, could someone explain to me in more detail how to install on ubuntu stack v3, such as where are the files to modify and those things, really the documentation is very poor or I am very stupid, a video would be great, since I should not be the only one with this problem. thanks

hi @kapotik, happy to help if I can. Here’s a video about how to install The Things Stack using docker -> https://youtu.be/XgPSU4UkDuE

Soon, these videos will be embedded in the documentation - we’re working on that now :slight_smile:

Do you mind sharing where you had trouble in the documentation? I’d like to try to make it as clear as possible. I guess you’re following the guide here? -> https://www.thethingsindustries.com/docs/getting-started/installation/

1 Like

Hello, thank you very much for answering and for the video, I will try to install, if I do not come back for you, :joy: :joy: :joy:, I think the problem is that you assume that who is reading the guide is an expert in docker, and many Sometimes this is not the case, I have been using The Things Network for 3 years and after having carried out many successful projects, now I want to test your solution for private lorawan, but I do not use docker, I do not want or I can not start studying docker to install the V3 stack, and you are the only solution that gives for its installation, maybe if you had an option to do it by linux command line, I would not open this post, and yes, you will answer me that with docker it is easier, but they are leaving out all the people who do not use it.

In my opinion if the guide is only going to contain the installation with docker, it should be done step by step,
step 1, do this … and leave the command to copy paste in the console
step 2, do this … and leave the copy paste command in the console. etc etc.
So people like me could install it just by following the sequence. but hey, it’s just my opinion, maybe there more people who use docker than I imagine.
I am also very grateful for all the work you do, thank you very much.

Sorry for my bad english, google is my friend!!

best regard
Nestor

1 Like

hello, after
docker-compose pull

i get:
[3741] Error loading Python lib ‘/tmp/_MEIClTRP0/libpython3.9.so.1.0’: dlopen: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28’ not found (required by /tmp/_MEIClTRP0/libpython3.9.so.1.0)

I’m sure it has to do with the installation of docker compose, but after searching and trying many things from google nothing works

solved, reintall docker compose

new error, after:
docker-compose run --rm stack is-db init

Starting the-things-stack_redis_1 … error
Starting the-things-stack_cockroach_1 …

ERROR: for the-things-stack_redis_1 Cannot start service redis: error while creating mount source Starting the-things-stack_cockroach_1 … error

ERROR: for the-things-stack_cockroach_1 Cannot start service cockroach: error while creating mount source path ‘/the-things-stack/.env/data/cockroach’: mkdir /the-things-stack: read-only file system

ERROR: for redis Cannot start service redis: error while creating mount source path ‘/the-things-stack/.env/data/redis’: mkdir /the-things-stack: read-only file system

ERROR: for cockroach Cannot start service cockroach: error while creating mount source path ‘/the-things-stack/.env/data/cockroach’: mkdir /the-things-stack: read-only file system
ERROR: Encountered errors while bringing up the project.

solved: problem the HDD, replace HDD

I hear your pain, there’s always some tech that takes away the simple old-school solution. In theory, the docker scripts could be reworked to allow a command line install.

Moving on, I’ve come here, what should I do with this?

$ CONSOLE_SECRET="your-console-secret"
$ SERVER_ADDRESS="your-server-address"

I did the video as is:

root@ttn:/the-things-stack# docker-compose run --rm stack is-db create-oauth-client \

–id console
–name “Console”
–owner admin
–secret “console”
–redirect-uri “https://layka.ga/console/oauth/callback
–redirect-uri “/console/oauth/callback”
–logout-redirect-uri “https://layka.ga/console
–logout-redirect-uri “/console”
Starting the-things-stack_redis_1 … done
Starting the-things-stack_cockroach_1 … done
Creating the-things-stack_stack_run … done
INFO Connecting to Identity Server database…
INFO Updating OAuth client…
INFO Updated OAuth client secret=console
INFO Setting owner rights…
INFO Set owner rights

then:
docker-compose up

everything starts fine as in the video without errors, but when I access layka.ga I get this:

console

Please help!!!
I know I’m close to achieving it

SUCCESS!!!
I had an error in the ttn-lw-stack-docker.yml file, copy paste stuff, thank you very much for taking the time to make the video, I wouldn’t have done it without it, now let’s try !!!

exito

1 Like

Awesome! Where was the error? I’m so sorry it took me a long time to respond, we’ve been really busy with The Things Conference.