How to remove TTN from a MultiTech Conduit

I have installed the TTN software on my Conduit and have everything working. Now I want to go back to the default operation of the Conduit. How do I disable the TTN network server and return to the default MultiTech network server? I have tried stopping the TTN server with “/etc/init.d/ttn-pkt-forwarder stop”, which stops the service, but it restarts when the Conduit reboots. How do I completely disable the TTN software and get the default LoRa software running again?

First hit on google:
http://www.multitech.net/developer/products/multiconnect-conduit-platform/conduit/resetting-the-device/

1 Like

Thanks, but that doesn’t restore all the software to its original state. The reset only restores some of the configuration settings to their default, i.e. network IP address, DNS, etc. After I restored the basic configuration to get it back on my network, the LoRa functionality was still not working. What files are changed by the TTN install? Is there any “uninstall” script that can be run?

Which installer (and instructions) have you used to install the software? (Uninstalling depends on what has been installed)

I used these directions:
https://www.thethingsnetwork.org/docs/gateways/multitech/aep.html

I was able to get it working again by re-installing the factory FW again, and then rebuild my environment again. It would be helpful to have a simpler method to switch between networks during development and testing.

1 Like

Due to the different models and firmware versions creating and maintaining such a method would require considerable effort. Resetting the gateway to factory settings (including reinstall of the firmware) takes less than 10 minutes so would it be worth the investment? If so, are you volunteering to invest time in it?

1 Like

For me the easiest method has been to do a firmware update on the gateway, even if it was already running the latest firmware. It seems to get rid of TTN but keep all the other configuration in place, like IP settings and so forth.