Http integration not sending anything

I hope i am posting to the correct forum…

my aim is to send all the uplink data from ttn->google firebase using http integration and firebase REST API.

i’ve seen the video. i’ve setup google firebase as anonymous so that it can accept any json key value pair in the realtime database via http/https post/put request. url is i can verify it works using postman chrome app. by using post or put request, any json keyvlue pair appears instantaneously in the firebase console. i’ve tried both http as well as https for firebase and they both seem to work using postman.

unfortunately, i can’t get the ttn http integration to send uplink data to any webservice…to check i changed url to a service similar to requestbin but nothing appears there. to confirm any request i make to that url using postman is instantly reflected…but i see no request coming from the TTN

on the other hand, if i send data to ttn using postman using dowlink , i can see data in ttn console but it doesn’t get forwarded to address above
i can see downlink data in the ttn application console using postman->http integration, so it means http integration is setup correctly for downlink. (using url:
i don’t see what mistake i am making. i use ttn-eu server.

so i conclude that http integration is only accepting messages but now forwarding them to 3rd party services…

any help is highly appreciated because i can connect firebase to many other service…

[one month later]

Still not working?

i made a mistake there, it was working then also but with a delay of like 4 hours or something! i use it to log all data from TTN to google firebase using REST API. it works but i see data on the google firebase console after a few hours.

Is this still the case i.e. that you have to wait a long time for events to come through from the HTTP integration? I’ve been expecting a lot of events today and so far nothing has come through… does this work or not? Better to integrate your own backend stack with Docker perhaps?

try a realtime non-sql database like google firebase. it is accessible via REST API. for me it works with both http as well as https although the documentation says only https works. that is the only way to know for sure! Wait for 1 day.

can give the link of the video?

The video is linked from, in Beware it dates back to March 2017, so might be outdated for some details.

Many more things to see in Labs!

Oh, I just noticed that it’s also linked from the documentation page, which you might need to read? See