I can not establish connection OTAA; It works ABP but it does not downlink!

Hello, I confirm that my knowledge is limited, but I researched a lot and I am at least a month locked with this problem !! I really need help, can anyone help me?

I’m following the “MobileFish” tutorial (link below), but since I’m in Brazil I use the American band #define CFG_us915 1 and RFM95-915Mhz

I had a mono-channel gateway, but now I have a gateway Dragino LG02. I have already registered the Gateway on the TTN website to help the community expand.


Library -> MCCI_LoRaWAN_LMIC_library by IBM, Matthis Kooijman, Terry Moore …

I send packets to the TTN successfully if I make an ABP connection !! But I am not successful in sending packets if the connection is OTAA and nor send the downlink of the TTN (ABP or OTAA).

I’ve also tried several tutorials, but I’ve always had the same problem! Works ABP; Does not work OTAA and downlinks !!

Below is the OTAA connection log! Stay in this loop forever

______________ OTAA connection log _____________
Packet queued
516548: EV_TXSTART

9826011: EV_TXSTART
10206155: EV_JOIN_FAILED
10529685: EV_TXSTART

11056731: EV_TXSTART
20380341: EV_JOIN_FAILED
12062704: EV_TXSTART

Below are the donwlink attempts with ABP!! Remembering that with the ABP connection the packets arrive in the TTN; I just can not do downlinks.

I blocked the TX / RX channels, so every msg that is sent arrives in the TTN

My gateway is configured :

Canal TX -> Freq 923300000 / SF12 / Cod Rate 4-5 / Bandwidth 500Khz
Canal RX-> Freq 917000000 / SF17 / Cod Rate 4-5 / Bandwidth 125Khz

You can see that the data arrives normal in TTN with ABP

You can also see that a TTN has sent the downlink!

At my gateway a message appears on the TX channel, but my node does not execute anything!

I’ve tried other libraries like arduino-lmic-master, but always the same problem !! OTAA does not work; ABP works, but not downlinks!! I believe that if the connection problem with OTAA is solved, it will solve the Downlink problem as well, and vice versa, so I went through the 2 problems!!

Can someone help me? I swear I do not know what else to do!!

One more thing, I put the code and the library I’m using in github:

I’ve never gotten the OTAA to work with the Dragino Hat either with US915. It has the same problem, no join received but the packets look fine in TTN and my local gateway. ABP works OK (mostly).

Thanks Pendleto … I will close this thread because I was able to send a JoinRequest to a TTN and the TTN is returning me a JoinAccept !! I’ll try to solve this or I’ll create another topic !!

Hi Marcos. How did you solve it? I have the iC880a gateway very close to me and a things Uno and I just can’t push data via OTAA to the TTN. I get the below screenshot.

Those are the three gateways I have added to TTN

There goes my code on serial for OTAA

As for the errors (please don’t post images for what is just text) the “Join not accepted: denied” only proves that the node did not receive a Join Accept. For that, the network might have silently rejected the Join Request, but it could also have accepted it after which the node somehow did not receive the Join Accept. And the “no_free_ch” just means the node is trying too fast, which you can ignore for now as that would not happen if the join succeeded.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.