IC880a - Raspi 3B V1.2 - Concentrator start failed: lgw_start Issue

I have been trying to setup a gateway using this tutorial.


All of the TTN side appears to be working and I can see live status data appearing on the Gateway console.
However I am getting the error below.

2024-05-26 10:05:57.017 [RAL:INFO] SX130x LBT not enabled
2024-05-26 10:05:57.017 [RAL:INFO] Station device: /dev/spidev0.0 (PPS capture disabled)
2024-05-26 10:05:57.017 [HAL:INFO] [lgw_spi_open:101] Setting SPI speed to 8000000
2024-05-26 10:05:57.017 [HAL:INFO] [lgw_spi_open:135] Note: SPI port opened and configured ok

2024-05-26 10:05:57.529 [HAL:ERRO] [lgw_start:764] Failed to setup sx125x radio for RF chain 0
2024-05-26 10:05:57.530 [RAL:ERRO] Concentrator start failed: lgw_start
2024-05-26 10:05:57.530 [RAL:ERRO] ral_config failed with status 0x08
2024-05-26 10:05:57.530 [any:ERRO] Closing connection to muxs - error in s2e_onMsg

I am using a Pi to IC880a adaptor board.
I have confirmed that SPI is being sent to the correct pins on the IC880a.
I have tried taking the reset sequence out of the start.sh, sending the reset sequence manually before starting the application.

Is there test application I can use to independently confirm the SPI comms are working, without running the entire basicstation application?

Or any other suggestion for confirming that my IC880a is still alive? Currently only the Power status LED illuminates.

But you say

What pin have you used for Conc Card reset ?

I am using gpio25 for the reset and I have confirmed that is going to pin 13 in the IC880a.

This is what the live data packet looks like on the gateway.

  "name": "gs.status.receive",
  "time": "2024-05-26T10:05:57.000757223Z",
  "identifiers": [
      "gateway_ids": {
        "gateway_id": "eui-b827ebfffeaa2841",
        "eui": "B827EBFFFEAA2841"
  "data": {
    "@type": "type.googleapis.com/ttn.lorawan.v3.GatewayStatus",
    "time": "2024-05-26T10:05:57.000472334Z",
    "versions": {
      "firmware": "",
      "package": "",
      "platform": "rpi - Firmware  - Protocol 2",
      "station": "2.0.6(rpi/std)"
    "advanced": {
      "features": "rmtsh",
      "model": "rpi"
  "correlation_ids": [
  "origin": "ip-10-100-6-66.eu-west-1.compute.internal",
  "context": {
    "tenant-id": "CgN0dG4="
  "visibility": {
    "rights": [
  "unique_id": "01HYT5TBW842S5TTSXF40AWM57"

Is there a simple python program I could use to establish if spi comms is working correctly on the Ic880a?

Is there a method for changing the SPI clock speed? I would like to try it running at 2Mhz as opposed to 8Mhz to see if that helps.

Yes, been covered previously on the Forum - search is your friend :wink: If connecting using flying leads vs an interface pcb that may be a good option to try, though usually associated with slugged conc cards where manufacturers added slower level shifters to interface :man_shrugging:

P.s. where are you in UK?

Hi - I have see many posts suggesting reducing the SPI clock speed. But I can’t see how to do it, either from Basicstation config change, or from the CLI changing the SPI device config.

I am using an interface PCB - but just clutching at straws with the SPI clock speed.

I’m starting to wonder if my ic880a is dead.

I’m in Suffolk.

I have solved the SPI start up issue by using this command
sudo RADIODEV=/dev/spidev0.0 LORAGW_SPI_SPEED=2000000 /opt/ttn-station/bin/start.sh
which sets the Pi SPI speed to 2MHz.

I had a subsequent issue where the Reset script was not toggling the reset pin, prior to start up.
I change this to a manual python script and it works every time now.
import RPi.GPIO as GPIO
import time

GPIO.setup(25, GPIO.OUT)



This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.