iFemtoCell - no ethernet with fixed IP


(Ud Lo Ra) #1

I am finally configuring an iFemtoCell. Following more or less the wiki (not everything is up to date, starting from the led colors…) I was able to set everything, including updating to 3.4.5 and installing SPF.
I was even able to set a fixed IP address for Ethernet connection, and soon after I saw some packets going to TTN. Hurrah. However, matter of minutes, the gateway was no more connected.
I am able to access the administration pages thorugh the local name, although I was almost never able to connect to its local wifi (i.e., it connects through the ethernet cable).
The configuration part shows the address I have put, which I can also find in the lan.config file. However, the overview page shows a self-assigned IP (like ifconfig does too).
Thanks for your help.


(Madhuvarsha) #2

I see there is a link with in TTN on Kerlink iFemtoCell
https://www.thethingsnetwork.org/docs/gateways/kerlink-ifemtocell/

There is s statement used on link https://www.disk91.com/2017/technology/internet-of-things-technology/kerlink-lorawan-wirnet-ifemtocell-review/ :

If your firmware is 3.3.3 or earlier you must make some change in the / user/spf/bin/execute_spf.sh file. As the IpTables rules have been changed you need to replace the iptable -A option by a -I (i upercase). Otherwise your iFemToCell will never connect to TTN.

May helpful.


(Ud Lo Ra) #3

Thanks, forgot to tell I installed 3.4.5, however I was able to connect to TTN, but it is no more connecting to Internet.


(Ud Lo Ra) #4

Just to know: I solved (through the Kerlink helpdesk). The configuration mechanism did miss a line in the connman configuration, in particular in the lan.config file “Type = ethernet” was missing.