Impossible to re-connect gateway after recreating

Hi guys,

I’ve Dragino LPS-8 gateway and worked fine until I deleted it in console and recreated again under new name/GatewayID (EUI is still the same). Since that moment is GW disconnected. Searching through the documentation I found Troubleshooting Gateways | The Things Stack for LoRaWAN that GW has to be disconnected some time due to expiration connection timer used for UDP solution.

So I kept GW disconnected more than 48 hours, tried to reboot, power-off&on, etc… but I’m standing still on the same place - gateway is disconnected. Tried this by using more GatewayIDs
but without affect.

Can you guide me what to try in next step or what I made by wrong way or skipped-over.

Did you update the firmware to lgw-5.4.1633695703 ?
I used the same Gateway EUI as in V2 and a new Gateway ID

Web interface says:

lg02_pkt_fwd : 1.2.1-1
lora-gateway : 1.2.7-3
haserl-ui : 1.1.1-2

Via SSH: Version: Dragino-v2 lgw-5.4.1618196981

And NO, I did not updated anything. Just re-created.

That will be your firmware version - should see same with Web GUI - System → System Overview → 3rd item down?

Update to 5.4.1633695703 downloading the file from Dragino support location 1st then head to System → FIrmware Update and follow your nose, pointing update to download location :slight_smile:

Am still investigating if inplace upgrade ‘keeping settings’ a viable option or if need to do factory reset before loading settings for V3 is a must do…

OK. Absolutely have no idea what happening but GW is connected affter firmware upgrade (did not tick “keep setting”) and GW is connected now. Even has different GatewayID in console and in LPS-8 web interface.

So thanks for help and I’ll be really happy if you provide some explanation “why”. :slight_smile:

Sorry cant help too much there guess its because… software! :roll_eyes:

Tried multiple ways but didnt seem to carry settings so could only get back online after a full reset at which point GW started with default EU settings for V3 - in line with last attempt, and is now happily online and appears stable.

Looks like @rharte came to same conclusion yesterday

Atleast anyone following behind us now has a potential solution until Dragino fix settings carry forward for future updates. Am sticking with UDP for now inline with @wolfp 's comments in the other thread also.