Issue with LT-22222-L

Hello, I’ve recently problems with my device, which was working properly before. The issue is that downlinks can’t get into the device, they queueing up. Before, every downlink get into the device and this device respond every time by changing inputs/outputs and nowadays that work very randomly (maybe one from dozens of downlinks get into the device). The issue is solved by restaring the device, but it’s still works for low amount of downlinks (usuall one, maximum three) and after that, device start working randomly again.

Is it registered in V2 or V3?

I just recently purchase a LT 22222 L. My issue is that I cannot receive downlinks. The user manual is useless. I have been trying to ask Dragino for assistance. What a terrible experience.

Congratulations, a very complete and comprehensive problem description. Very useful for us to be able to help you solve your issues.

May-be you want to try again and tell us what works and what doesn’t and details about what you tried to make things work?

Using dragino LPS8 gateway. Trying to configure LGT92 tracker. Used USB-TTL device to flash and configure. Couldn’t get device to connect to TTN. Then purchased LT22222L relay IO control. Connected right out of the box. Used AT+CFG to display device keys. Created application on TTN. First problem. When using TTN repository could not send uplink data. Downloaded dragino decoder v1.5.ttn. Then able to send uplink but no downlink. Integrated to Data Cake. Receive error that download links not configured. Contacted dragino support. Have been sending emails back-and-forth for past 2 weeks. On TTN invited dragino support as collaborator. Gave them full access to my application. Refer TTNv3 Support Guide PDF. Frustration because dragino manuals contain broken links. Receive error HTTP Status 404 – Not Found / Apache Tomcat/9.0.31 (Ubuntu).

I can confirm that a Dragino LT-22222 works with TTN and Datacake. I have this configuration running since many month for monitoring and charging a 12V battery.

It looks like the downlink-encoder or the rights for the API-keys are missing. I would propose to read the instructions for Datacake very carefully, they give you important hints.

Another hint: Did you configure the “Downlink” in the settings of Datacake?

I am unable to configure in DATACAKE. When I try to select downlinks I receive error: This device’s LoRaWAN Network Server has not been configured yet. Please check the settings in the configuration.

When I go back to TTN and select my application. And then select Downlink. I am confused on how to test. I’m suppose to use JSON payload. Not sure what to type in box to test Downlink.

I used the keys printed on the inside of the box. I didn’t add an API key in TTN. I’ll go down that rabbit hole.

Same problem as before. When trying to use link in gateway manual for LSP8 page 29. http://wiki.dragino.com/index.php?title=Main_Page#MQTT_Forward_Instruction
Receive dead link error: HTTP Status 404 – Not Found / Apache Tomcat/9.0.31 (Ubuntu). Is this Linux?

These instructions are not required or useful for TTN. Forget about them. Make sure your gateway uses TTN and forwards data to TTN. Everything else should be configured at TTN and Datacake.

So that needs solving and isn’t a Dragino issue.

Dragino’s reorganisation of the links to documentation is a PitA - but the links from the product page work if you start from there each time.

However MQTT on the LPS8 is totally irrelevant, or any other aspect of the gateway as long as the settings are largely out of the box.

The 404 status shows, yes, it is Linux - as in the web server for the wiki - but again not relevant beyond telling me enough to understand why Edwin may have moved away from it.

You can use the documentation for the LT-22222-L to figure out the downlink you want. And then use the TTS downlink documentation to slot those bytes in to the starter decoder that TTS provide and provide it a dummy JSON payload (example in the docs)

You were right. I needed an API to link my device. I was able to link a Datacake Token back to TTN as a webhook. Now I can send downlink data from the Datacake console to LT22222L and activate relays. I then created an API on TTN and configured device for uplink. I am still having a problem sending data from TTN to Datacake as an uplink.