Issue with setup in Australia - Gateway and Device Not Communicating

Hello everyone,

I’m experiencing an issue with my LoRa setup in Australia Region. I have the following configuration:

  • Device: ESP32 with SX1262 Waveshare module
  • Gateway: Raspberry Pi 4 with SX1303 915MHz, using the sx1302_hal library
  • Configuration File: Template file from sx1302_hal library global_conf.json.sx1250.US915
  • TTN Cluster: Registered in Australia Network Cluster
  • Frequency Band: AU_915_928_FSB_2

Despite the gateway connecting and running successfully, my device can’t seem to join the network, and I’m not receiving any messages in TTN. I’ve checked the setup and can’t find anything obviously wrong.I couldn’t find a configuration file for Australia, so I used the US 915 config file, assuming they were similar and there wouldn’t be any issues. But now I’m wondering if that’s actually the source of the problem.

Here’s what I’ve tried:

  1. Using Europe 868 MHz Configuration: I switched to a Waveshare SX1303 868MHz module, registered in the Europe Network Cluster, and adjusted the frequency band and gateway configuration accordingly. This setup worked, with LoRa frames being received by TTN.
  2. Using US 915 MHz Configuration: I reverted to the original configuration with SX1303 915MHz and registered in the US Network Cluster. I used the same global configuration file (global_conf.json.sx1250.US915), and the setup worked, with messages being received by TTN.

Given this context, I’m seeking advice on what might be causing the issue with my Australian setup. Is there something specific about the AU_915_928 frequency band that I’m missing? Could the issue be with the gateway configuration, device settings, or other environmental factors?

Any assistance or guidance would be greatly appreciated. I’m open to further suggestions and ready to provide additional information if needed.

Thank you in advance

Most likely.

Why not download the global_conf.json from the gateway setup page on the console?

And search the forum for device not connected issues - comes up frequently.

And tell us what firmware you are using on the ESP32 to complete the picture.

Yes. Please consult the lorawan regional paramters.

Yes, yes and yes. Long range RF is hard to get right. The first things to make sure of is to use compatible settings on the gateway (download from the TTN console the correct fle, don’t use something random), the device (needs to use the same frequencies the gateway does) and make sure there is at least 20 feet and a wall between the two (long range RF overmodulates easily and you won’t like people shouting in your ears either)

Sure, let me try that way. I followed the setup instructions from the Waveshare SX1302 RPi HAT guide, so I didn’t really think about the configuration details and just went with the provided instructions.

I have ported the this (link) github repo to ESP-IDF.

@kersing I’ll make sure to use the correct config file from the TTN console, check that my device and gateway use the same frequencies, and keep enough distance between them to avoid overmodulation. I’ll test these things and let you know how it goes. Thanks again for the help!

Highly recommended to read the TTS documentation and then “interpret” the vendor instructions - TTI do LW all day every day, the vendors doc’s writers not so much.

BeeGee produces awesome stuff but if I was starting out with LW, I’d not port something known to work to a different SDK, I’d use it as is to confirm that things are working. RadioLib for Arduino is well supported here and it is designed to support other platforms but I’ve not tried it in IDF.

Ideally I’d get a known good combo of hardware & software so that I’m not looking at this many variables in the great bug hunt. You will get to the end of this marathon, but you started out just being able to run a few km, so this is a rest before the next leg(s)!

The Learn section is essential reading, many questions are answered via forum search and the docs have troubleshooting sections.

Thank you for the advice and encouragement.
I have a working setup with a Raspberry Pi and an SX1302 868MHz gateway, along with an ESP32 using an SX1278 module as the node. I used the library from manuelbl. Now, I’m looking to switch to the SX1262 module but couldn’t find a suitable example for it, which is why I ported the code from Arduino to ESP-IDF.

Based on your suggestions, I tried using the global_config.json from the TTN console directly in my gateway setup, but it didn’t work. Instead, I manually adjusted the frequencies in my configuration file based on the global_config from TTN, and now it’s working as expected.

However, I’ve noticed that devices fail to connect when I use these versions of Regional prameter and LoRaWAN specifications:
And working fine with these versions

Thanks again for pointing me in the right direction—your input has been invaluable.

Which version you need to use depends on the stack you are using on your device, LoRaWAN 1.0.4 stacks are few. Most are still 1.0.2 or 1.0.3. The repo you based your code on is based on MCCI LMIC which states ‘ The library has only been tested with LoRaWAN 1.0.2/1.03 ‘. So 1.0.4 was never going to work.

Can you clarify - have you switched to using an 868MHz concentrator card and are using it for the AU plan?

The library you’ve linked to is a port of LMIC and only supports up to v1.0.3

LW is set on standards, there should be no need to manually adjust the frequencies and by doing so, the gateway is working on one configuration and TTN thinks it is working on the standard.

If you search the forum for the library I suggest above you’ll find it supports both radios.

You may want to check out your window to see if there is a panel van with an few antenna’s on the roof, if there is, pack an overnight bag.

No, I haven’t switched to an 868MHz concentrator card for the AU plan. I have both 868MHz and 915MHz concentrators, but I’m using the AU plan with the 915MHz concentrator.

Regarding the library, thanks for pointing that out. I realize now that it only supports up to LoRaWAN v1.0.3. I must have overlooked that detail, but I understand it now. Thanks for bringing it to my attention.

Thanks, I understand now. I didn’t think much about the version in my node code, and I missed that the library was only tested with LoRaWAN 1.0.2/1.0.3. it explains why 1.0.4 wasn’t going to work. I’ll make sure to correct it.