Issues using Installer instructions and firmware 5.2.1

Hello,

I’ve got a number of AEP Conduits for a project and I’m running into an issue with the installed after upgrading to the latest firmware (5.2.1)

I’m running the script as detailed at https://www.thethingsnetwork.org/docs/gateways/multitech/aep.html however even when running it via sudo I get the following errors:

Installing TTN Multi Protocol Packet Forwarder
Installing mp-packet-forwarder (3.0.25) on root.
sh: /tmp/opkg-bRDNHv/mp-packet-forwarder-iPnvG0/preinst: Permission denied
To remove package debris, try `opkg remove mp-packet-forwarder`.
To re-attempt the install, try `opkg install mp-packet-forwarder`.
Collected errors:
 * pkg_run_script: package "mp-packet-forwarder" preinst script returned status 126.
 * preinst_configure: Aborting installation of mp-packet-forwarder.
 * opkg_solver_install: Cannot install package mp-packet-forwarder.
Get up-to-date TTN configuration for packet forwarder

module.js:340
    throw err;
          ^
Error: Cannot find module '/opt/lora/merge.js'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:945:3
installer.sh: line 826: /etc/init.d/ttn-pkt-forwarder: No such file or directory
The installation is now complete.
Check the gateway output using:
tail -f /var/log/lora-pkt-fwd.log
(It might take some minutes for the first output to appear!)
Check the gateways last seen status in the TTN console after
a few minutes to verify the setup is working correctly

I’m assuming that this is due to the missing javascript library, however I’m struggling to find out how to get those libraries installed.

Switching to mLinux is not an option unfortunately due to client requirements.

Is there a way I can either install the library or fix the permissions to get this working?

I had hoped that the web UI “TTN” dropdown would be sufficient, however that doesn’t appear to be the case as the server is still showing as “not connected” even after saving the settings and rebooting.

Thanks in advance.

For those playing along at home, the only way to use the dropdown for TTN in the GUI is if you select the “legacy” packet forwarder option when adding the gateway to TTN.

As soon as you do that, the gateway shows up as connected in the TTN console and the packets start flowing freely.

Looking at the error messages I doubt that is an option. I’ll try to find some time over the weekend to look into this.

1 Like

Thanks @kersing - to be honest we’re only using these devices because it was the customer request. I’d far rather be using the RAK7249’s given they talk all kinds of different ways to different setups including our own Chirpstack solution and TTN.

I definitely won’t miss configuring the Multitechs… :slight_smile:

Hi, I’ve had the same issue with Multitech conduit 5.2.1 firmware, and found that the problem was that the /tmp folder was mounted with noexec option, so opkg cannot execute preinst script.
To make it works I’ve just remounted the /var/volatile mount point (where /tmp points) with the following command: /bin/mount -o rw,exec,remount /var/volatile
Hope that it could help someone!

3 Likes

Thanks - we’ve gone back to the RAK gateways for now, the Multitechs really don’t feel as good as they should for the price they’re being sold at in our opinion, but it’s good to know we can do this in future if we need to.

Thank you for this! Very helpful!
I ran
/bin/mount -o rw,exec,remount /var/volatile
then
sudo sh installer.sh

to get it to work, and I did not select the legacy packet forwarder in TTN.

Also note that it shows an error, which does not currently seem to matter:

Installing TTN Multi Protocol Packet Forwarder
Installing mp-packet-forwarder (3.0.25) on root.
Configuring mp-packet-forwarder.
Get up-to-date TTN configuration for packet forwarder

module.js:340
    throw err;
          ^
Error: Cannot find module '/opt/lora/merge.js'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:945:3
Starting ttn-packet-forwarder: OK
The installation is now complete.
Check the gateway output using:
tail -f /var/log/lora-pkt-fwd.log
(It might take some minutes for the first output to appear!)

Same issue here after remote firmware upgrade. Your fix cured it. Thanks. It’s not a great management experience if you’ve got a lot of these to look after is it ?