Join accept not forwarded to end device

Heya! I installed an LPS8 Dragino gateway in my house and let my end devoice join via that router. However, for whatever reason it does accept the Join Request, but after then nothing happens. I use LMIC node, so it should be fine.

Only gateway data (besides metrices every 30 seconds):

End device logs:

Logs from the gateway itself:

LMIC node logs:

000000001842:  doWork job started
000000001901:  Event: EV_JOINING
000000330506:  Event: EV_TXSTART

000003751842:  doWork job started

000007501842:  doWork job started

I tested this device with a different gateway (don’t know which one, it’s from my school) and then it joined properly. Any idea what could cause this?

Oh, btw, the gateway seems to have a bunch of “txin” but not “txok”, maybe that’s related?

I did find that maybe a port is blocked on my router, but not sure about that. Any help would be appreciated :slight_smile:

My own idea was that either DIO0 or DIO1 is not properly connected, but everything seems fine to me…

Well, I fixed it by setting LMIC_CLOCK_ERROR_PPM to 30000, and now it works properly. Not sure why, but hey, it’s fine!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.