Kerlink iFemtocell - connect to TTN?


(Disk91) #1

I'm looking to join TTN with a Kerlink iFemtoCell gateway. The base is wirenet but the kernel and systems looks really different than the IoT Station. I tryed to install the packet forwarder manually but it donot start.
Does anyone of you did an installation on it ? Help welcome.

Paul


Gateway Key used in Semtech Packet Forward Mode?
#2

Hi,

It worked as expected when I followed their wiki.
Do you have access to it ?


(Disk91) #3

Thank you for your answer I'm waiting for the wiki access... as usual with kerlink getting access to the documentation is long and complicated ... (boring)
I may have it soon (anyway if you have an export I may save some time).
Paul


(Disk91) #4

I've got my access rights :wink:


(Disk91) #5

I configured the Semtech Packet Forwarder. Is it the only one available ? noone yet compiled the TTN one ?
It's the first time I use Semtech PF with TTN. Is it normal to not see the gateway connected to TTN ? (actually I did not yet send data from any device)


#6

@disk91
I never tried to use the TTN one.

Regarding the configuration of Semtech's packet forwarder what did you use ?
I think it is required to change the address & port to "router.eu.thethings.network:1700", depending on your country.


#7

What a shocker of a service. I can’t believe that you can sell a product with ZERO documentation and then not even give access to a WIKI with info without jumping through hoops and wait for ages till someone get’s back to you. What a waste of time.

I will be sticking with MultiTech - at least they are selling a reasonably well-documented product, and their support is actually responsive.


(Wodec) #8

Any updates on this ? I’m also trying to connect an iFemtoCell of Kerlink to the TTN (or TTI) without succes :frowning:
I’m waiting for access on the Kerlink Wiki but it’s quite urgent to get it online…

Any help is welcome !


#9

I can help to setup the gateway, I have several working here. But I don’t think I am allow to send you their software.
Nevertheless you should really insist on support, I can not imagine that they sell gateway without any doc or software…


(Disk91) #10

check this :


(Wodec) #11

Short update, maybe usefull for others:

  1. ssh to the gateway ((user: root / pass: pdmk-xxxxxx )

  2. make directory .updates
    cd /user
    mkdir .updates

  3. copy ipk file from usb flash drive
    cd /user/.updates/
    cp /run/media/sda1/spf_3.0.0-klk1_4.0.0-wifc3_klk_wifc.ipk .

sync
kerosd -u

reboot

  1. fetch Gateway ID in local_conf

  2. edit Global_conf
    cd /user/spf/etc
    vi global_conf.json

    “gateway_ID”: “xxxxxxxxxxxxxxxxx”,
    “serv_port_up”: 1700,
    “serv_port_down”: 1700,
    “server_address”: “router.eu.thethings.network”,

  3. delete local_conf.json

reboot


#12
  1. fetch Gateway ID in local_conf
  2. “gateway_ID”: “xxxxxxxxxxxxxxxxx”,
    6.delete local_conf.json

I need to check but from what I remember calibration data are stored in local_conf.json. So you do not want to erase it :wink:
Also, no need to copy gateway_ID is you do not delete it as all filed of global_conf are replaced by local_conf.


(Tord) #13

@Oliv, @Wodec or @disk91. Have you tested with the new spf_3.1.0-klk15_4.1.3-klk7_klk_wifc.ipk also? I seem to have difficulties to connect to the router, but there could be other issues.


#14

@Tord, I have to check but I think that I am up to date, dans not connection issues


(Disk91) #15

I also not able to connect to the router with the spf Klk15 …
On a second kerlink I installed firmware 3.3.3 that solved my LTE stick detection problem but the spf seems to not be compatible with TTN.
I’ve tried to downgrade the spf on version klk11 but the issue is the same. Potentially it comes from the firmware 3.3.3 ; I know they have changed firewall rules… Any idea, anyone solved that?
I assume it is related to this in the release note:

"Also, note that the firewall now has rejection rules at the end of the INPUT and OUTPUT chains, to properly disallow non-matching traffic. This implies that new rules ‘appended to the chain’ will never be matched; if you want to add new rules, either make sure to add them to a file in /etc/firewall.d/, or if you add them to your application, ‘prepend’ them to the chain by using “-I” (insert) instead of “-A” (append). "

and /user/spf/bin/execute_spf.sh is creating new iptables rules with -A
So I changed the -A by -I in this file and now it works…


(Disk91) #16

I confirm it works well by modifying the execute_spf.sh script, even with spf klk15


(Hugo) #17

Hello, I have the same issue.
Gateway is kerlink ifemtocell, using semtech packet forwarder (pre-installed) and TTN show as “no connected” in the console.
I have no joined any motes.


(Hugo) #18

Hi Tord
where i can download this latest version of Packet Forward for ifemtocell
spf_3.1.0-klk15_4.1.3-klk7_klk_wifc.ipk
?

Thanks in advance.

Hugo


(Hugo) #19

Hi Disk91, the line that be need to edited and change -A by -I is this line?
[ -n “${PORT}” ] && iptables -t filter -A OUTPUT \

This change is need for what version of spf ?

Thanks in advance.

Hugo


(Hugo) #20

Hi guys
Here i am trying to setup a ifemtocell kerlink gateway to TTN.
I register the gateway, but get the No connected message.
I have not registered or joined motes at this point.

The “Gateway Key” is used for Semtech Packet Forward or must be ignored and only is used for TTN Packet Forward ?

Thanks in advance.

Hugo