Kerlink iStation disconnected

Hi guys,
I have configured my Kerlink iStation gateway as described in the documentaion. It is also registered on the things stack. The packet forwarder runs with the global_conf.json of the things stack.
In the log the uplinks are also acknowledged.
However, the gateway is still not connected to the things stack and I don’t know what the problem could be.

What makes you think that - because that will give us a clue of what you might need to do.

I thought it was connected because i changed the server addresse In lorafwd.toml under gwmp the node to “” and the port for uplink and downlink to 1700. As described in the documentation. What else do I have to change ?

So you’ve not seen any hard evidence that you are connected - nothing in the logs of the gateway or on the v3 console?

No, i have not. In the Overview of the things stack is the gateway still disconnected.

Have you entered the serv_gw_key correctly ?

“serv_gw_key”: “NNSXS.blah.blah”

This should match your Gateway Link API key that you generated

Just a thought.

Do you know where i can enter this key (in which file)? sorry i am not a professional.

On my system I added the key value to local_conf.json - the file is in the same folder that you downloaded global_conf.json

I cant find any file like local_conf.json

ok, the serv_gw_key value can go into global_conf.json if you don’t have a local_conf.json

But I think the idea is that the local_conf will override the values that have been created in global_conf.json (assuming you clicked the download global_conf button).

Normally you would put the personal stuff in there (like “contact_email” : “value”) and perhaps key values related to gps (assuming you have gps enable to provide better timing).

It is also important in the global_conf.json to adjust the “antenna_gain” to match the published dBi gain of your antenna (allowing for a few db loss in the cabling, depending on the length and quality of coax between antenna and gateway).

Sorry I am a little confused. I have now downloaded the globa_conf.json as here:
Now I have to put in the file /etc/default/lorad at CONFIFURATION_FILE the globa_conf.json I just downloaded right ?

P.S. when I downloaded again, only globa_conf.json was downloaded in the folder I just had open. But not local_conf.json

You aren’t going to get a local_conf.json file from a button that says global_conf.json.

But you don’t need one as long as you remember that you have edited the global_conf.json by putting in the serv_gw_key with the API key to suit and restart the gateway.

Is it important in which line I put the serv_gw_key here?

Next to gateway_ID?

Pick one and try it, if that doesn’t work, try the other, if that doesn’t work, try both.

Please do not post pictures of things that can be copied & pasted.

unfortunately still does not work.
So I have done:

  1. downloaded global_conf.json
  2. added “serv_gw_key”: “API Key” to global_con.json (in all three combinations)
  3. put global_conf.json into /etc/default/lorad
  4. enabled the packet forwarder in /etc/default/lorafwd
  5. edited lorafwd.toml (node = and for down- and uplink port 1700)

did i miss something or made a mistake ?

When you say “API Key”, you have actually put an API key in there? The start NNSXS.

Did you power cycle the whole gateway each time?

Yes, i copied the API from the consle. And yes, I rebooted the gateway a few times.

Can you copy & paste the global_conf.json section with removal of some of the letters in the API Keys, just so another set of eye balls can have a look see.


        "gateway_conf": {
                "gateway_ID": "7076FF005605031F",
                "serv_gw_key": "NNSXS.VNN...PXJQA",
                "server_address": "",
                "serv_port_up": 1700,
                "serv_port_down": 1700,
                "servers": [
                                "gateway_ID": "7076FF005605031F",
                                "serv_gw_key": "NNSXS.VNNPXA...PXJQA",
                                "server_address": "",
                                "serv_port_up": 1700,
                                "serv_port_down": 1700,
                                "serv_enabled": true