Kerlink LoRa IoT Station 868


(Jabp) #1

Hello everyone,
I had a lot of problems with this gateway due to the lack of documentation.
First of all, I followed the TheThingsNetwork tutorial to setup and install the forwarder into the gateway. Everything went ok until anywhere is said that in the /mnt/fsuser-1 directory it has to appear a directory call “thethingsnetwork”. After a lot of time I get this directory but I reboot, restore factory settings and reflash so many time that I cannot remember.
Nice, I finally get the directory with the “global_conf.json” and the “local_conf.json” and then…what? There is no more information about what you have to do to link your fisical gateway with the thingsnetwork-console-gateway.
Second, to restore the factory settings I read at this forum that you must press the reset button 22 times (waiting to the GSM1 led to turn off, I guess). Is that really how it works?
Third, I tried to flash another firmware, I downloaded the 2 .zip files that appear at the bottom of the following page
https://www.thethingsnetwork.org/docs/gateways/kerlink/firmware-updates.html
one of them contains one file that is in the other .zip file. So I guess I have to replace one for the other, paste the result into a empty usb and that’s it, right? Why if I do that the USB is blinking all the time and the gateway keep reseting himself over and over for more than 15 min? I tried to flash the 2.3.3 firmware and the 3.1. I did not get any result and I had to reset the gateway to factory settings (I guess).
Fourth, now my getway is reseting himself again, and again, and again. The gsm1 led is blinking (actually is not blinking, just turn on and off like at 0.2 Hz but seems like is blinking).
Help, please.
Hope you could help me.
Thank you very much.
Best Regards.


(Jac Kersing) #2

A kerlink gateways firmware can not be downgraded, if you try the gateway will have to be restored by kerlink according to messages on the internet.
Your attempt to load 2.3.3 was probably a downgrade from the existing version.


(Jabp) #3

Thank you for answer. I really appreciate it. Anyway I still having problems if I try to install the 3.1 and I think is the current version.
There are someone who could help us about the TTN problem? There are some mistake in what I have done? I followed the steps at thethingnetwork.
Thank you in advance.


(Jac Kersing) #4

Do you have a debug probe? If not try to borrow one or visit someone with one. That is the only failsafe way to determine the current state of your gateway.


(Jabp) #5

Hello,
I do not have one. I will ask someone to get one.
Thank you :smiley: