Kerlink problem of disconnection w/o reconnection


(Disk91) #1

I’m using a Kerlink GW with last firmware and semtech packet forwarder. After a couple of days the gateway disconnect and it did not reconnect until rebooting it.

The log for spf is:
Nov 20 19:45:37 Wirnet local1.notice spf: I/ Programming FPGA with spectral scan firmware
Nov 20 19:45:39 Wirnet local1.notice spf: *** Beacon Packet Forwarder for Lora Gateway ***
Nov 20 19:45:39 Wirnet local1.notice spf: Version: 3.1.0-klk16
Nov 20 19:45:39 Wirnet local1.notice spf: *** Lora concentrator HAL library version info ***
Nov 20 19:45:39 Wirnet local1.notice spf: Version: 4.1.3-klk8;
Nov 20 19:45:39 Wirnet local1.notice spf: ***
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: Little endian host
Nov 20 19:45:39 Wirnet local1.notice spf: I/ Using default Gateway EUID: XXXXXXXXX
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: found global configuration file global_conf.json, parsing it
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: found local configuration file local_conf.json, parsing it
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: redefined parameters will overwrite global parameters
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: [main] TTY port /dev/nmea open for GPS synchronization
Nov 20 19:45:39 Wirnet local1.notice spf: INFO: FPGA supported features: [TX filter] [Spectral Scan]
Nov 20 19:45:42 Wirnet local1.notice spf: INFO: [main] concentrator started, packet can now be received
Nov 20 19:45:42 Wirnet local1.notice spf: INFO: Disabling GPS mode for concentrator’s counter…
Nov 20 19:45:42 Wirnet local1.notice spf: INFO: host/sx1301 time offset=(1542743140s:297897µs) - drift=-522490711µs
Nov 20 19:45:42 Wirnet local1.notice spf: INFO: Enabling GPS mode for concentrator’s counter.
Nov 20 19:45:42 Wirnet local1.notice spf: Could not bind

This looks like the described solution related to cellular communication (my case) but poly_pkt_fwd is not used in my configuration. I’ve tried killing execute_spf script and relaunch it but it is not changing anything (basically the spf is restarting itself).

Do you have any solution ?
Sincerely,
Paul


(Disk91) #2

Sounds like
killall -kill spf may do the job