Laird RG1xx join failures on two channels

I have a friend who has a Laird RG1xx on AU915 - exact model number & firmware revision available when he wakes up - where the Murata ABZ based device fails to join if it uses either 916.8 and 918.2 aka the first & last TTN channels.

If the device uses any of the other six channels, all is well, the join proceeds normally. Once joined, uplinks flow nicely.

The existing forum posts appear to confirm my suspicion that Laird sort of hides firmware info by streamlining in to the release notes PDF without any corroborating info, so I have two questions please

  1. Has anyone ever come across anything like the channel failures before?
  2. Is there any way of verifying else where that the latest firmware is actually

I’m wary of any technical updates that are supplied in this sort of format as it’s reliant on someone keeping the PDF up-to-date rather than it being automagically listed in some download directory.

My current workaround is to remove the two channels from the firmware, it joins, the CFList turns them back on and all appears well with the world. But I’d rather have all eight to hand as a mass deployment is due soon.

My Laird RG1xx is US902-928.

The latest firmware is “Laird Linux gatwick-laird-” per my Laird RG1xx dashboard. That is consistent with the current user guide at


@nu3e, thanks for this - the info I had plus this nudged the client in to updating their gateway.

And then getting out a different brand to confirm that their Laird has some issue - configuration or otherwise - and it’s not a bizarre firmware issue that I’d generated. When in doubt, blame the programmer!

1 Like

I am sorry to post a new, but related, topic here. I just do not see a way for me to start a new topic.

I have a new Laird RG191 gateway and a Seed Studio LoRa E5-HF developer device. I registered both the Gateway and the endpoint on the console; but, the endpoint never joins. The console shows that the gateway is disconnected; however, the modem’s web console shows active connections to the server and the WIFI router. The WIFI light on the gateway blinks green.

There is a “drift” in this thread that seems to indicate that the Laird gateway is not useful. Please give me a nudge. I’m new to the IOT TTN, but a rather ancient software/hardware guy.

What firmware version are you using on the RG1xx? And what settings?

And what channel plan settings are you using…assume they are consistent across GW & node?

Not much help to you right now but apart from the recent report which suggesed 1 instance of a channel issue on a recent build per Nick there are no other reports of major problems with the Laird (use forum search) and can say I use lots of them for my own and collaborator/clients use so we will dig in and help where we can… Nick’s client appears to have worked around the problem using another GW and not actually solved so we dont know if systemic, firmware or a point hardware issue at this moment and need more data.

No, there isn’t any such implication, this was a thread about someone’s gateway having issues and me not having clarity about where to find the firmware updates in a ‘normal’ manner.

Further enquiries revealed the gateway to be second hand and the other gateway in the box he was given was entirely mute, so it seems he was passed a couple of broken units, most likely run with no antenna on them. A new TTIG solved the debugging. A new RAK gateway is in place. The Laird & other gateways are in landfill.

Although I still don’t like finding a PDF of release notes to get a link to the latest firmware.

Nooooo! More e-waste! The WB50NBT modules used in these that provide the network interfaces and system management in these were like rocking horse droppings when I looked to try and repair a couple of my failed systems back in the summer - 52wkLT & £60-80+ per with a significant MOQ, damn I could have used! (ok shipping from AU probably made impractical :man_shrugging: ) :slight_smile:

Radio 0 Center: 904.3, Radio 1 Center: 905.1.
These cover the E5’s span:
+CH: 8; 8,903900000,DR0,DR3; 9,904100000,DR0,DR3; 10,904300000,DR0,DR3; 11,904500000,DR0,DR3; 12,904700000,DR0,DR3; 13,904900000,DR0,DR3; 14,905100000,DR0,DR3; 15,905300000,DR0,DR3;
Gateway software: Laird Linux gatwick-laird-
The Things Network Legacy - US preset is being used
Forwarer: semtech,, ports 1700/1700

Thank you for your reply. I included the frequency plan info in a reply to descrtes.

That’s the old setting, you should use these days.

1 Like

WOW!! That did the trick! TTN shows a brand-spanking new message from the endpoint.

Thank you very much for the help. Now, on to other quagmires. ;-D

Quagmire avoidance: - read all of this, just don’t do all the video in one sitting.

ANY other information on the internet should be cross-referenced with the docs for validation. Many sites have v2 info, some sites are based on luck, so always check in here:

1 Like