Link ADR rejection received

Hi All,
I have a Things Indoor Gateway on my TTN console. I have a TTGO board with the LMIC LoRaWAN library. I wanted to send data through the gateway and see it on my end device console. I was able to successfully send “Hello, World” message however I have noticed that I started getting the “Link ADR rejection received” message on the end device console. On the Gateway console, I see a lot of uplink and downlink messages being sent. All the uplink messages are empty and I am not sure how my TTGO board is sending these messages. I am attaching some screenshots of the console

Gateway console screenshot → Screen Shot 2021-07-13 at 2.43.28 PM

End device console → Screen Shot 2021-07-13 at 2.43.15 PM

The end device is connected to the TTN through ABP. Any help will be appreciated

LoRaWAN Version–> MAC V1.0.3

Hello, I have the same problem but using OTTA, the strange thing is that, today in the morning, the problem was solved, but when adding a temperature sensor and loading the new firmware, once again there is the problem.
Have you already solved the problem?
###############################
Hello again, I just read in the LMIC documentation, that the default MAC version is v1.0.3 and I had v1.0.2 selected, all this at the frequency of us915, I made the change in the Node configuration and apparently, it was solved, Greetings!
#######
Captura de Pantalla 2021-07-26 a la(s) 12.43.06
#######
Captura de Pantalla 2021-07-26 a la(s) 12.45.41

Captura de Pantalla 2021-07-26 a la(s) 12.46.03

Have you checked your device has the adr option activated? I faced the same long time ago and it was because I was forcing the Data Rate instead of using the Adaptive Data Rate.

If it did not, the network would not be sending it ADR commands.

The situation described can only occur with a node running in ADR mode.

Note also that the problem was solved - it was a difference in LoRaWAN protocol versions.

@rnicolas, please be aware that topics don’t close automagically - it’s unlikely the issue still exists after two months.