LMIC + 1CH ESP32 Gateway Downlink not working

Hey everyone

I’ve been debugging this very strange problem for the last couple days without much luck. I’ve had luck setting up both ABP and OTAA with my gateway without issue. Joins are working and uplinks as well. But no matter what I do, I can’t get downlinks to work. The gateway interface is confirming that the downlinks are sent out, but LMIC isn’t registering anything. I’m using the standard ABP sketch, and this library for my (1 channel) gateway https://github.com/things4u/ESP-1ch-Gateway.

Things I’ve tried:

  • Using only a single channel on ABP
  • Tried different clock errors from 10% up to 100%
  • Tried downlink on both ABP and OTAA configurations
  • Tried different RX windows (normally I haven’t configured these from the standard, but thought it was worth a shot)

What’s really weird to me is that joins are working, and join accept messages are being received. Does anyone have a suggestion on how to debug this?

Sorry there is no support for not LoRaWAN compatible gateways on this forum.

1 Like

That’s fair. If I can ask you to make a guess though, would you say that the issue is likely with the gateway or the node?

This could a downlink datarate issue (this took me a while to understand myself).

The JOIN itself always uses the same region-specific uplink and downlink settings, as far as I know.
The JOIN accept message sets up a custom data rate for the RX2 window, for TTN this is SF9. So your node might not be listening at the right settings in the RX2 window for downlinks. This could explain why a JOIN works, but a regular downlink does not.

Like @kersing said, use of a 1-channel “gateway” is really discouraged.
If you want to experiment, I can recommend to get a TTIG, it’s only about E100,- shipped.

1 Like



And for that reason the issue won’t be dug into here. But please avoid confusing it further with falsehoods.