Lorix One and V3

Hello, I’m a 100% beginner to LoRaWan, just got my Lorix One Gateway and started to dig into the topic. Here’s what I did:

  • Installed the gateway, has network connectivity
  • Registered the gateway in TTN V3
  • Configured the Gateway accordingly

While everything seems to work, the connection from gateway to TTN doesn’t succeed, I get the following error:

2021-01-30 17:26:26.041 [TCE:VERB] Connecting to MUXS…
key usage : Key Cert Sign, CRL Sigx00
2021-01-30 17:26:25.998 [AIO:INFO] tc has no key+cert configured - running server auth only
2021-01-30 17:26:26.610 [AIO:ERRO] [3] WS upgrade failed with HTTP status code: 401

So it looks like an authorization issue but I have no clue how to fix this. Any ideas

Best regards


Hi Jorg! Welcome to the forums. It sounds like you’re getting a great start!

To configure the gateway, are you using Basic Station LNS or CUPS? It looks like you need to make sure you upload the correct CA cert and token. See instructions for both in the CUPS/LNS docs, try LNS first as it’s a little easier → LoRaWAN Network Server (LNS) | The Things Stack for LoRaWAN

The cert you need on that gateway is the DST Root X3 → Root Certificates | The Things Stack for LoRaWAN

Installed X3, but still get error:

2021-02-04 11:27:58.056 [AIO:INFO] TLS server certificate verification failed: The certificate is not correctly signed by the trusted CA

I’m connecting to V3 stack, is that OK?

Finally solved the issue. Uploaded new certificate and also new API key, now the gateway is online.

1 Like

Lorix has the correct procedure and .pem file to upload to the gateway.


1 Like


I have a connection problem to The Things network with the Lorix One.
I followed the explanation here :

But I have still this log :

station diagnose key usage : Key Cert Sign, CRL Sign
station diagnose certificate policies : An2022-11-29 10:15:39.784 [TCE:INFO] Connecting to INFOS: wss://eu1.cloud.thethings.network:8887
station diagnose 2022-11-29 10:15:49.879 [AIO:ERRO] [-1] WS connect failed: NET - Failed to get an IP address for the given hostname
station diagnose 2022-11-29 10:15:49.881 [TCE:ERRO] TC connect failed - URI: wss://eu1.cloud.thethings.network:8887
station diagnose 2022-11-29 10:15:49.885 [TCE:INFO] INFOS reconnect backoff 0s (retry 0)
station diagnose 2022-11-29 10:15:50.339 [AIO:INFO] ./tc.trust:
station diagnose cert. version : 3
station diagnose serial number : 5E:C3:B7:A6:43:7F:A4:E0
station diagnose issuer name : CN=ACCVRAIZ1, OU=PKIACCV, O=ACCV, C=ES
station diagnose subject name : CN=ACCVRAIZ1, OU=PKIACCV, O=ACCV, C=ES
station diagnose issued on : 2011-05-05 09:37:37
station diagnose expires on : 2030-12-31 09:37:37
station diagnose signed using : RSA with SHA1
station diagnose RSA key size : 4096 bits
station diagnose basic constraints : CA=true

Do you know where it come from ?

Thanks for yout help