Lostik Uplinks always sent with SF12

I am pretty new to LoRa and tried to do a small setup with a LoStik and a raspberry. I connected a moisture sensor and managed to send the values measuered to a gateway.
My stick always sends data with SF12, even if downlinks are coming with SF9.
I don´t know what´s the problem here. Can anyone help me?

Kind regards

You need to instruct the lostik to use another spreading factor, how you do that depends on the software you are using. As you don’t provide any information on what that software might be (and I don’t want to spend time researching what might be available and next guess what you could be using) you need to find out how to do that yourself. As it seems the lostik is based on a microchip module I would start with the RN2483 commands manual from the microchip site,

Hint: you know what hardware and software you are using, we don’t know the details of every LoRaWAN device on the market so when asking a question please provide links to what you are using, that way we don’t have to google.

BTW, you are not sending data to a gateway, you are sending data to the network. If you are lucky there are multiple gateways in your vicinity receiving the transmission and forwarding it to the backend. LoRaWAN is not WiFi where you transmit data to a specific access point.

First of all, thanks for your quick answer and sorry for the sketchy post.

Yes, sorry for the incorrect formulation. In my case several gateways are receiving the message.

I am using Lostik from Ronoth which comes with RN2483.

I used the manual to set sf9 with radio set sf sf9
but still, the module sends with sf12.

Can someone help me? I am really stuck here.

Which manual is that? I’d say you need something like:

mac set dr 5

The value depends on your region. For EU868 data rate 5 will use SF7, and mac set dr 3 will get you SF9.

See What is the difference between mac and radio commands in RN2483? and Modulation and Data Rate.

1 Like

Hi Arjanvanb!
Thank you so much! I just did a quick try with setting your command and it works! That´s awesome! I have to take a closer look on the links you have sent! (y)
I thought if I set adr on and choose a SF it works, but that command to set the dr, I did not see.

1 Like

With radio commands you change the setting of the Lora stack. However the mac layer overrides these settings when you are sending LoRaWAN data. Radio commands are useful when you switch the mac layer off.

@arjanvanb good catch!