Maybe a problem with my RHF0M301

Hi!
I’m using a RHF0M301 gateway from Seeed, all looks great, my gateway is active in Ttn but when I run the command line :slight_smile:

pi@ttn-gateway:~ $ systemctl status ttn-gateway.service

I have this :slight_smile:
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: ### [DOWNSTREAM] ###
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # PULL_DATA sent: 3 (100.00% acknowledged)
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # PULL_RESP(onse) datagrams received: 0 (0 bytes)
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # RF packets sent to concentrator: 0 (0 bytes)
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # TX errors: 0
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: ### [GPS] ###
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # Invalid gps time reference (age: 1599838003 sec)
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: # Manual GPS coordinates: latitude 50.22679, longitude -66.35434, altitude 30 m
Sep 11 16:27:03 ttn-gateway ttn-gateway[2959]: ##### END #####
Sep 11 16:27:04 ttn-gateway ttn-gateway[2959]: INFO: [down] for server router.us.thethings.network PULL_ACK received in 94 ms

Is it all right? Because I see the message that tells me : Invalide gps time reference…
So it’s not 100% fine I think…
So if you have some clues for me I would be greatful :slight_smile: really.
Thanks in advance!

Does the gateway have a gps receiver? If so, is there a gps antenna connected?

If there is no gps or no antenna there is nothing to worry about. That is a normal message. If there is a gps with antenna you need to make sure it can receive satellite signals.

Hi thank you for the reply!

“Does the gateway have a gps receiver?”
Firstable, Yes the gateway has a gps receiver

" If so, is there a gps antenna connected?"
Yes, all I used are there :https://www.seeedstudio.com/LoRa-LoRaWAN-Gateway-915MHz-for-Raspberry-Pi-3.html

Second issue, I have ThingsUno card (RN2903) and when I try the communication between my gateway and this card, I see that my card is on the 868 MHz frequences… Why?

Thanks in advance for your help ;)!

If you search Google &/or the forum you’ll find plenty of entries about setting up a Pi to use a GPS on a LoRaWAN install.

Because you ordered that version or your supplier shipped the wrong version …

We can help further if you tell us what region you are in to verify the frequencies.

Hi! Thanks for the reply descartes!
I live in Canada, for more details I live in Sept-Îles (Quebec). So the frequencies should be 915 MHz I think.

I think, therefore I am!

Yes, Canada uses US902-928: https://www.thethingsnetwork.org/docs/lorawan/frequencies-by-country.html#c so your gateway is fine, you need to sort out the Things Uno with your vendor.

Whilst it’s a nice to have for timing at the gateway, TTN doesn’t use the GPS location, so it’s not something that will stop the gateway being functional. As I said, this is a common issue with Pi based gateways so a little searching should yield answers for the correct configuration.

Okay, that’s a good news! I’ll search and come back to you if I have news.
Thanks again buddy!

Hey it’s working, I just had to change the global_conf.json file that was in the packages… It was a file for EU’s frequencies… It was just as simple as this, sorry for inconvenience!

1 Like

That controls the gateway, not the node. You reported a problem with the node being the wrong frequency band for North Ameria.

It’s not clear if you did so, but please do not use 868 frequencies in Canada; it’s not only incompatible, it’s illegal, as those frequencies are used for other things (mobile telephones, etc) there.

1 Like

Blockquote It’s not clear if you did so, but please do not use 868 frequencies in Canada; it’s not only incompatible, it’s illegal, as those frequencies are used for other things (mobile telephones, etc) there.

After changing theses files, the frequencies displayed on ttn has changed, please see below:
captureTtn

And don’t worry buddy I know all the stuffs you mentioned before, that’s why I was concerned about it :slight_smile:
I think it’s due to the RN2903 chip that can work on European frequencies to, and the fact that the things uno tried to connect with my gateway ( set-uped with european packages)… it might be why I saw frequencies like 868MHz on ttn before (it doesn’t make sense I know haha). But please if you have clues about that, feel free to share your ideas :slight_smile:!

Or it could be (with high probability) the fact that I missread the things displayed on ttn console haha, and the frequencies like 868,865 MHz displayed were from the gateway and the node has always been correct … By thinking about it, I think that was that…