Mbed LoRaWAN-demo-72


(Smetanin) #1

Hi, everyone!
Anybody have successful experience with mbed LoRaWAN-demo-72 ?
I have IC880A + P-NUCLEO-LORAWAN1(SX1272MB2xAS) end node.
I tried to follow this guide from mbed, because it looks familiar.

  1. I tried to use OTAA activation method. I copy&past Device EUI, Application EUI, App Key to mbed code, compile&load, and nothing. My node didn’t send any packet to the gateway.

  2. I tried to use activation method. I copy&past Device EUI, Application EUI, Device Address, Network Session Key, App Session Key to mbed code, compile&load, and nothing again))).


#2

Have you had any other node join through your gateway? I had success with this:https://os.mbed.com/teams/Semtech/code/LoRaWAN-demo-72/


(Smetanin) #3

Yes, the same node with example code from CubeMX. What should I change in LoRaWAN-demo-72 to make it work?


#4

Sorry, but your question makes no sense as there is not enough information to know how to advise you other than suggest you try again with the similar example I gave. When you say that it didn’t send any packet, did you see any join activity? Did you enter the same DEVEUI, APPEUI & APPKEY as you used in the CubeMX example or have you registered the node as a new device in your TTN application?


(Smetanin) #5

I use the same DEVEUI, APPEUI, APPKEY like in CubeMX example and there isn’t any join activity. Maybe its problem with version 7:5077515 of LoRaWAN-demo-72 ? I have LoRaWAN-lib files at revision 12:d405d2dd43b9, SX1272Lib files at revision 12:d405d2dd43b9 and mbed revision 170:e95d10626187.

The image below shows my VT100 application status
screen-lora


(Cslorabox) #6

Since you have your own gateway, something it’s very much worth doing is modifying the gateway code to print/log packets received, regardless if they are valid or not. That might be considered by some to be too noisy in production, but it’s very useful when doing early node work. There’s basically code to do this already there, just commented out. If you run the packet forwarder manually you’ll see it, otherwise it’s wherever the output usually is, ie /var/log/syslog

One major thing to make sure of is that your node is built for the band plan applicable in your region and which your gateway is using. Modifying the radio management code to print out via serial the actual frequencies it is setting can be useful.


#7

Hi @Smetanin, I decided to try this for myself, knowing that a few months ago it used to work. I found a NUCLEO-L073RZ board and added the SX1272 mbed shield. I used the current version of LoRaWAN-demo-72 with the mbed online compiler and can confirm that it no longer works, just remains at joining and I cannot see any traffic on the gateway - I need to look into this further. Incidentally, I note a similar result from @BFH_SAM2 - I-CUBE-LRWAN V1.2.0 and TTN - join problems


(Smetanin) #8

Thanks for helping, can we make some issue for mbed or semtech team?


#9

I posted this question yesterday - https://os.mbed.com/questions/82357/LoRaWAN-demo-72-bootcamp-no-longer-works/


#10

Hi @Smetanin - just to let you know that i haven’t seen any response to my query on the mbed forum.

However, I just exported the LoraWAN-demo-72 from the online compiler (as Make GCC_ARM) and ran the Makefile in a linux environment with the current version of arm-none-eabi toolchain - it works!


(Smetanin) #11

Continuing the discussion from Mbed LoRaWAN-demo-72:

Hi, I exported LoRaWAN-demo-72 from the online compiler (as Make GCC_ARM), ran makefile in linux but nothing changed. Even changing Device EUI, Application EUI and App Key in commissioning.h didn’t help.
I took Loarawan demo from here, gcc version 4.8.4 20141219 (release) (4.8.4-1+11-1)
Maybe i do something wrong?


#12

I have now moved on from the LoRaWAN-demo-72 to mbed-os-example-lorawan. I got this running today with the SX1272 mbed shield installed on a NUCLEO_F103RB by adding a section for the NUCLEO_F103RB into mbed_app.json


(Hamocat) #13

I experienced that same problems with LoRaWAN-demo-72/76. Thank you nicbkw, I also managed to get mbed-os-example-lorawan working relatively easily with a STM32L072 Discovery board.

Are there any other interesting examples that are worth exploring?