Migration of TTIGs to The Things Stack CE (v3)

@KrishnaIyerEaswaran2 earlier you mentioned v3.12.3 is scheduled for 23 June then you mentioned v3.13.2 as git link

My console state v3.13.1


I can see already a gateway with the same EUI in v3 console but disconnected. And it seems the gateways shows connected still on v2.

You mean that the claim process on v3 will be available from v3.13.2? (or v3.12.2?)

Thanks for confirming that!


Yes, because 3.13.2 is scheduled for 23 June …


I see the confusion. I’ve fixed the version in my comment. We are in the process of internal testing. Once we are confident, we’ll deploy to the community clusters and inform users here.


6 posts were split to a new topic: Move The Things Kickstarter Gateway to V3

I’m about to register 3 new TTIG on TTN. Should I register them on the V2 console before gateway registration is disabled or should I wait a couple of days to register them directly on the V3 console?
Thanks in advance for your precious advice.

Absolutely no harm in registering it on v2 so it’s working right now.

I think we are awaiting the release of instructions on how to claim our TTIGs on v3.


Are there any news about this migration and the claiming process? Thank you in advance.

Yes, it’s working but it needs some refinement.

We’ll share an update later today/tomorrow on this along with V2 going read only. Please stay tuned.


It apparently already has - for gateway registration.

So i undestood… later today / tomorrow is equal to “tomorrow”? right?

TTI worked until after business hours to solve a (last) niggling issue so it will be tomorrow (depending on your timezone :slight_smile: )

1 Like


In the meantime i was trying the command line interface…

Claim a Gateway | The Things Stack for LoRaWAN (thethingsindustries.com)

But the docs didn’t report what you need to use as <claim-authentication-code>

And getting:

FailedPrecondition desc = error:pkg/deviceclaimingserver:gateway_not_authorized (gateway not authorized for claiming)

As, in fact did Jac & myself to help get this done.

1 Like

It’s the gateway WiFi password

Thanks @descartes, i’ve tried the wifi password printed on the gateway but still getting gateway_not_authorized

Show me the command you are using, without the password and if you are overly paranoid, change the EUI

1 Like

./ttn-lw-cli gateways claim <the eui in this format: AABBCCDDEEFFGGHH> --authentication-code <the wifi password printed> --user-id <my user id to log into the console> --target-gateway-id <i found this already created in the new V3 console: algorni-lora-gateway-goa01-v3> --target-cups-uri https://ttn.eu1.cloud.thethings.network/

Just running the CLI that I’ve downloaded few minutes before: lorawan-stack-cli_3.13.2_linux_amd64 on my WSL2 on my Windows 10 but I was able to log in properly as I did

./ttn-lw-cli use eu1.cloud.thethings.network

Close but you can’t use an ID that you found in the console.

The ID has to be unique to the entire of TTN

ttn-lw-cli gateways claim The-TTIG-EUI --authentication-code TTIG-WiFi-Password --user-id your-user-id --target-gateway-id gateway-id-you-want --target-cups-uri https://eu1.cloud.thethings.network:443 --target-gateway-server-address eu1.cloud.thethings.network --target-frequency-plan-id EU_863_870_TTN

You will have to ./ttn-lw-cli login before hand

1 Like