Mikrotik gateway is "Disconnected" on overview page

I’m probably doing something wrong.

I have a MikroTik Lr8 gateway with v.6.49.2 firmware. I has worked on v2 and has recently stopped working there. I decided to add (not claim) it to v3 community TTN.

On the MikroTik :
Network server is the IP of “eu1.cloud.thethings.network” which is “”, ports are 1700 UDP.
Channel Plan is EU 868. Forward is Valid and Error, Network is Public

The “gateway EUI” is the “hardware ID” of the MikroTik. “Gateway ID” is identical on both.
Frequency plan is Europe863-870 (SF9…)

On the MikroTik I only see Rx packets.

To try to understand what’s going on I have used wireshark to look at the IP traffic.

I see UDP packets on port 1700 going to and from Large packets to TTN and 4 byte responses from TTN. For instance 02 a0 00 02 … and the response is 02 a0 00 04 which seems to correspond with a ### 5.2. PULL_DATA packet ### from packet_forwarder/PROTOCOL.TXT at master · Lora-net/packet_forwarder · GitHub

So the IP stuff seems fine. I even see the Gateway ID in the UDP packets.

Do you have any hints on other things i can check ?

Kind regards, Ivo

You’re looking very very hard at the molecules moving along the pipe.

But is there any water flowing - like the connect heartbeat every 30 seconds or so on the console. Or uplinks from your device(s)?

Please change that to valid only. Packets with CRC errors should not be forwarded to the backend, they just waste bandwidth and processing cycles.

I saw periodic packets from the gateway to TTN and responses. About one every 10 seconds.

Thank you for your answers and patience. The gateway works now.

Mikrotik has a configuration field called “Gateway ID” this field is initially empty. It also shows a non editable “Hardware ID”.

The MikroTik “Gateway ID” has absolutely nothing to do with the TTN “Gateway ID” and is in fact the TTN “Gateway EUI”.

Initially I didn’t notice because the “Gateway ID” I chose just happens to be a valid hexadecimal number. It fits fine in both fields (padded with zeros).

The MikroTik “Hardware ID” is not used in the UDP protocol, only the Gateway ID / EUI is. It’s just there as a hint of something you maybe could use as a value for the Gateway ID / EUI. I suspect the “Name” in the MikroTik config also has nothing to do with the TTN “Name”.

I my case my Hardware ID is a decimal number, it didn’t stand out to me as a EUI or MAC.

The other confusing thing for me is that UDP seems to work, the Gateway sends packets, TTN responds. A naïve expectation would be to see some kind of “I do not know who you are” messages in the TTN responses. I’m guessing that is not really a scalable solution because the load balanced UDP engine on the TTN side would have to look up which EUI’s actually exist.

I have had all this working on V2 but have no idea what my settings were there. I have a bad memory for solved problems.

Kind regards, Ivo

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.