Mosquitto can't schedule MQTT downlink (TTN v3)

I’m trying to set a downlink on my The Things Stack v3 application using Mosquitto (v1.6.9).

I’m having some problems in scheduling a downlink, but I can’t understand where the problem may be. Here’s the code that I use to schedule it:

mosquitto_pub -h -t "v3/antenne-lopy@ttn/devices/lopy-001/down/push" 
-u antenne-lopy@ttn -P "{MY_API_KEY}" 
-m '{"downlinks":[{"f_port":15,"frm_payload":"VR7dRW==","priority":"HIGH","confirmed":true}]}' -d

and the output is:

Client mosq-Fj5C4KmeMeWuB2qCqY sending CONNECT
Client mosq-Fj5C4KmeMeWuB2qCqY received CONNACK (0)
Client mosq-Fj5C4KmeMeWuB2qCqY sending PUBLISH (d0, q0, r0, m1, 'v3/antenne-lopy@tnn/devices/lopy-001/down/push', ... (76 bytes))
Client mosq-Fj5C4KmeMeWuB2qCqY sending DISCONNECT

so the downlink should be scheduled (am I wrong?)

I tried to check all the events with mosquitto_sub..., but when I try to queue a downlink, it doesn’t recognize anything, so, I think that it is not even reaching the TTN app.

edit: If I look to the application’s live datas, I can see that there’s a ‘subscribe application’ event, this make me think that I actually reached the app, maybe the problem is the downlink payload format?

please help and sorry for easy english.

Sorry, don’t know the answer to your issue, however I notice you are using confirmed downlink which is known to cause issues (search the forum if need to know what/why). If possible avoid confirmed downlinks.

Have you tried your command line with a desktop app, just in case there is something more it can tell you or just build the request differently?

I use MQTT Explorer (all platforms) for debugging

I just tried, and I succesfully queued a downlink, using the same payload (removing “confirmed tag”), I tried to send the same payload with mosquitto but it doesn’t work.

Nevermind, I passed to a Python script using Paho, and it works perfectly, still don’t know why Mosquitto is not working