MQTT Configuration in Node-Red

I have to configure, MQTT to receive data in Node-Red
I did all the steps to receive uplink messages as mentioned in the documentation(Without TLS)

I have just started and i cant find where i went wrong.
It says connection failed

This helps me to overcome the error

Thanks for posting back that you solved it.

Looking at your images it seems you solved this by changing to Good, but please don’t let people guess from some image you post. So, next time please describe the problem in the title, and please don’t post images for text, such as for log files (which also includes a lot of unrelated clutter in that screenshot). See How do I format my forum post? [HowTo]


Aside: a panic button doesn’t feel like a good use case for LoRaWAN as due to using unlicensed radio, there is no real guarantee that the radio signal is received.

And for the MQTT output you may want to select “Output: a parsed JSON object”.

Sure, thank you for the suggestion

Also, I’m surprised this works:

MQTT topic

If you’re not getting messages then you may want to remove the < and > characters. (Also, you could use wildcards, like +/devices/+/up.)

Yes, sorry. I had to remove the < and > at both application ID and device ID places

Thanks for this, i will try this for sure.

Okay, final tips: also subscribe to the error events. Even just subscribing to all your application’s events using +/+/+/events/# and then passing all messages to a log file can be of great help while debugging at some later time. (Though you won’t get an error if the configuration of your topics is wrong; you’d just not receive anything then.) Also, don’t forget a catch node for errors that occur in Node-RED itself.

See an example in Why is Node-RED integration no longer supported?

1 Like