Multitech Gateway Conduit AEP Network Interface


(C Baudrit) #1

Hello , I changed the network interface configuration to DHCP Client and I can’t access the AEP anymore (192.168.2.1) can somone help me please ?


(Elvin Luff) #2

As you said, you changed it to be a DHCP client, so it needs a DHCP server to listen to.

Plug your device into something that has a DHCP server (like your router), and then connect to it through that :wink:

The device doesn’t listen to the 192.168.2.1 address as it’s not configured as a static IP any more. It will be assigned an IP address by your router now.


(C Baudrit) #3

Alright Thank you ! I didn’t have a router around me so I just did it with DHCP server for windows.
I’m quite new to this so I’m a bit lost haha !
So it works, thanks again !


(C Baudrit) #4

Well, I have another problem :frowning_face:
I changed back network interface communication back to default, but I can’t access it anymore.
Should I just reset my multitech at this point ?


(Elvin Luff) #5

Hi again!

I’ve never used the AEP version (only mLinux) so I’m not sure how the interface works. It’s likely that you set it back to Static, but did you configure the IP address again? If you didn’t check it, it could be anything now.

If you did ensure that it’s on 192.168.2.1, ensure that your computers networking is also static. Ensure your computer is manually set to:
IP: 192.168.2.2
Netmask: 255.255.255.0
Gateway: 192.168.2.1
I don’t know if you already did this, but it’s good to make sure.

If the above doesn’t work and you don’t know the IP, you have two options:

  1. Use the included USB serial port and manually set the networking through command line (you need Linux command line experience for this)
  2. Just reset the device and start over.

I don’t know how familiar you are with Linux CLI, but if you aren’t, it makes a whole load of difference when dealing with these kinds of products. Remember: There’s a whole operating system under there, which you can do whatever you want with if you know what you’re doing!


(C Baudrit) #6

Hello ! Sorry for the late reply

Yes it was set back on 192.168.2.1
So I changed manually my computer and it works, thank you !
It’s weird that I have to set that up again, I didn’t have to do it the first time I did it.

Well I’m a student, I I didn’t get into Linux that much yet so I don’t know too much what am I doing !

Anyway, thank you again for answering my novice questions ! :grin:


(Floodnetwork) #7

I don’t know if AEP has the same issue, but when running the mlinux version as a DHCP client I found it would only request an IP address lease once, even if the ethernet link state changed. I’d lose contact with the device even when I reserved an address in the DHCP server. All my mlinux devices are now static to avoid costly site visits.


(Lacie 13) #8

@Eelviny Hi! Sorry to bring up an old thread, but I am having the same problem! I tried manually setting my IP address, netmask, and gateway but I am still unable to connect to the interface. Do you have any ideas?

Also, I have tried holding the reset button for 30+ seconds and it still will not reset so I am unsure where to go next.

Thank you!


(Floodnetwork) #9

HI @Lacie_13 - If you’re setting up an AEP there are two things to look out for:

  1. Make sure you didn’t enable DHCP server instead of DHCP client
  2. If you set eth0 to be LAN you should be able to reach it, but if you set it to be WAN then you would first need to “allow remote management”, since it considers eth0 to be on the WAN now.

You probably can’t get in to change these settings so I’d suggest a factory reset and go through the settings again if it’s not currently deployed. The non IP67 one has a USB port in the front panel that allows you to login with a terminal to the CLI and check what the ethernet interface is configured as (if at all).