Need advice about join denied (SOLVED)

I have recently purchased a RAK7244 gateway , a THETHINGS UNO, and a couple of other sx1276 based devices.
My problem is that while I have been able to use the ABP protocol with RN2903 and RF95 modules to interact successfully with, I have been utterly unsuccessful attempting to use the OTAA protocol, and received only “join denied” responses.
I carefully followed THETHINGS UNO activation instructions for that device as well as the Adafruit instructions for their devices, and the gateway console will show Join Request and Join Accept, but nevertheless the join appears denied through OTAA, although I can use ABP protocol fine. I very much would prefer to use OTAA.
RSSI is very good at -28 or -30.
I’ve reinstalled the RAK7244 gateway software twice.
Can anyone help me troubleshoot this failure to join over OTAA?

Thanks in advance!

Edit: RAKWireless support solved the problem. :grinning: :grinning:

Change 16 to 17 in the /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/global_conf.json file and see if the issue is resolved.

It is possible that ttn modified some parameters and caused us915 to have this problem in join. We have fixed this issue and will release it in the next version of the gateway firmware.

Unfortunately, this is only a temporary solution, as the 16 that TTN (sometimes) requests might very well be 17 (soon) again. Please see ERROR: Packet REJECTED, unsupported RF power for TX - 24 and please add a link to that topic, and to, in the RAK forum as well, so RAK knows what to expect.

I have just done so, thanks for the heads up.

1 Like