Netvox R311A Door Sensor

Purchased and now working

Device takes 2 CR2450N batteries (not cheap)

Received APPEUI and APP KEY from Supplier (not available from the manufacturer) make sure to also ask for Netvox payload document as not on manufacturer web site (same doc for all netvox gear).

Device worked straight away

Payload:
Port 6
type : [version] [device type] [Report Type] [Netvox Payload Data ]
bytes : 1 1 1 8
value: 01 02 01 1E 00 000000000000 open
value: 01 02 01 1E 01 000000000000 closed

Type : [Netvox Payload Data] [Netvox Payload Data] [Netvox Payload Data]
[Battery Voltage :1 ] [Close/Open :1 ] [Reserverd :6 ]
1E 00 00 00 00 00 00 00
1E 01 00 00 00 00 00 00

Downlink:
Port 7
RR DD NN NN XX XX BB
01 02 00 01 01 2C 01

RR = Request Type

DD = 02 R311A device type

NN NN = 2 bytes: minimum reporting time Sec, factory default 00 01
00 01 = 1 Sec
XX XX = 2 bytes: maximum reporting time Sec, factory default ?? ??
01 2C = 300 Sec

BB = Battery voltage change report rate in 0.1V units

Still unclear how MaxTime is being used, as minTime definitely affects report rate

Still at a loss as to why there’s 2 buttons on the side of the unit, as the user manual does not differentiate between them. ??

Will update as I learn more

2 Likes

Hi ! I do have the same sensors, but I still cannot make them work with TTN.

-Gateway is connected to TTN.
-Application is already created with the APP-EUI & APP-KEY of the device.
-I do received data in the GW:

10:25:47  INFO: [TTN] semak.thethings.industries RTT 31
10:25:47  INFO: [TTN] send status success for semak.thethings.industries
10:25:53  INFO: Disabling GPS mode for concentrator's counter...
10:25:53  INFO: host/sx1301 time offset=(1559909879s:949887µs) - drift=-213µs
10:25:53  INFO: Enabling GPS mode for concentrator's counter.

lgw_receive:1165: FIFO content: 1 34 0 5 17
lgw_receive:1184: [8 16]
Note: LoRa packet

##### 2019-06-07 13:26:17 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 1
# CRC_OK: 100.00%, CRC_FAIL: 0.00%, NO_CRC: 0.00%
# RF packets forwarded: 1 (23 bytes)
# PUSH_DATA datagrams sent: 0 (0 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 0 (0.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
### BEACON IS DISABLED!
### [JIT] ###
# INFO: JIT queue contains 0 packets.
# INFO: JIT queue contains 0 beacons.
### GPS IS DISABLED!
### [PERFORMANCE] ###
# Upstream radio packet quality: 100.00%.
### [ CONNECTIONS ] ###
# semak.thethings.industries: Connected
# Semtech status report send.
##### END #####
10:26:17  INFO: [TTN] semak.thethings.industries RTT 30
10:26:17  INFO: [TTN] send status success for semak.thethings.industries
  • But there’s no Join, and no data is seen in Console.

How you manage to make them work with TTN?

I set-up the Conduit GW with the embedded NetworkServer using Node-Red and the devices worked well! They join the Network and I can see data coming… So what’s the issue when trying to connect with TTN? Any advice?

Thanks!!
Diego.

dmocci, / Diego

Sorry, just saw your message.

I am using AS923 version, what are you using?

Did your Supplier give you the :

  • App EUI
  • APP Key

I use OTAA connection

You need to load Decoder and Encoder (see attached)

Then to configure the netvox sensor you must send a command to it

FPort = 7
Confirmed = tick
Payload = Fields (JSON)
{“Configure”: “REPORT”, “MIN_SEC”:1 , “MAX_SEC”:300, “MIN_VBAT”:1}

Good Luck

I accept Cider or Lambrusco! :wink:

Code: R311A-Decoder-CustomIoT.txt (3.0 KB)
R311A-Encoder-CustomIoT.txt (1.2 KB)

Hi DCH_Project !

Thanks for your help.

  • I’m using AU915 band.
  • All devices are OTAA.
  • I do have the APP Keys and EUIs:
    -APP KEY: 5A-69-67-42-65-65-41-6C-6C-69-61-6E-63-65-30-39
    -APP EUI: 00-13-7A-10-00-00-00-00
    [They are all the same for all devices I bought]

Sorry, but where I must “load” the encoder and decoder?
Which is the issue here? Why they don’t work wiht TTN?

– Do you accept a good wine instead? (I’m from Argentina) :laughing:

Thanks,
Diego.

decoder encoder send%20JSON%20payload%20to%20device

After you install encoder/decoder code (as shown)

then
paste the JSON Command
{“Configure”: “REPORT”, “MIN_SEC”:1 , “MAX_SEC”:300, “MIN_VBAT”:1}
into the field (#4) then press Test

Then goto data logs to seelora transactions

Buenos Suerte

Hi DCH_Project

Amazing reply, thanks!

Unfortunately, I cannot get my Netvox devices work :disappointed_relieved:

I followed your steps: Paste the JSON Command and get the payload ok:

image

By the way, I enter the GW through SSH, and see the data from R311A coming trying to join, but without success:

lgw_receive:1165: FIFO content: 1 fa 2 5 17
lgw_receive:1184: [8 16]
Note: LoRa packet
lgw_receive:1165: FIFO content: 1 21 3 7 c8
lgw_receive:1184: [2 17]
Note: LoRa packet
lgw_receive:1165: FIFO content: 1 f9 3 5 17
lgw_receive:1184: [2 17]
Note: LoRa packet

There’s something missing? Sorry to insist… but I cannot figure out what’s the problem here…

Thanks,
Diego.

I would contact the supplier (not netvox) and confirm how they configured the device

Q1. Do you have other devices connected successfully on your gateway?
Q2. Are you seeing the payload from device to TTNServer? in the data tab? Please screen shot the data tab for me after pressing the encoder test button. Maybe wait 5min+ (slightly usure from your reply)
Q3; did you fiddle with the two buttons on the side of the device? These are undocumented to end users , details are only avail to suppliers/distributors. But I am concerened you could have accidentally factory reset the device (can a supplier or NETVOX) confirm button operation? (pretty please)

Yes, I used an Evaluation Board from Multitech and works OK.

NO. No data coming into the console.

YES, I made factory reset. You mean this “reset” makes the device not compatible or disarranges it.

The only additional information I got was the log from TTN, that shows a “msg error type”:

router_1           | 2019-06-14T20:04:01.690156792Z   WARN Invalid Uplink                           error=Message not valid: Protocol not valid: MType not valid: unknown type 7
router_1           | 2019-06-14T20:04:23.806420891Z   WARN Invalid Uplink                           error=Message not valid: Protocol not valid: MType not valid: unknown type 7
router_1           | 2019-06-14T20:04:28.403443777Z   INFO Handled gateway status                   Duration=9.028µs GatewayID=semak1
router_1           | 2019-06-14T20:04:46.900075479Z   WARN Invalid Uplink                           error=Message not valid: Protocol not valid: MType not valid: unknown type 7

Any advice on this msg?
I’m trying to get a reply from manufacturer as well…

Thanks!
Diego.

Any Update from Manufacturer?