New MultiTech packet forwarder available

Node Red does not receive any packets. For that purpose the conduit has its own back-end server that performs the same function TTN performs. Because connecting a packet forwarder to two back-ends (TTN and the loraserver running on the conduit) can cause conflicts that configuration is not supported.
You can use Node Red with an MQTT connector to get the packets from TTN, check the TTN documentation and this forum on how to do this, there is plenty of information available.

Thanks, sadly I cant get the TTN node working with my MT gateway at the moment per this topic

Not sure if its related to the node red version currently shipped with the MT. I tried upgrading node red but the upgrade is failing for some reason.

You could just use the regular MQTT node, you do not need to use the TTN node. The MQTT node requires a bit more configuration but works very well.

Perfect, I will give that a try. Thank you very much. :slight_smile:

Hi Kersing, I am use new version “installer.sh” to configure my gateway,and encountered problems in the process of configuring the gateway, Please click on the following link:

Did anyone tried this on Lorank8 ? :slight_smile:

Can’t you guess? Of course I did… (not these packages and installer as that would not work, however I have a build for Lorank8 around as well, configuration is a manual process)

Great job again! I’ll look at this! :slight_smile:

Perfect, tested and works well. Thanks

I have pushed a new version of the package to github to fix issues with the gateway not booting past the forwarder startup script on network errors. To install it, just run

wget -k https://github.com/kersing/multitech-installer/raw/master/installer.sh

on the conduit to get the newest installer and run it. Answer ‘2) No’ to the question if you want to update the configuration, wait while the new software is downloaded and started and you are done.

I have upgraded and will see how it goes. Thanks

So my gateway has run fine for a month and today it required the packet forwarder to be restarted. So there is still this same bug from the beginning hidden away somewhere :frowning:

Other users have confirmed there still is an issue. I’m still trying to reproduce it that is the first step to be really able to resolve it permanently.

can you tell me where this log is supposed to be?
usually when i copy something from a console, i include the command and path for reference. basically i installed the new packet forwarder called ttn-pkt-fwd, i have configured the gateway id and key to match with TTN but it is still showing offline. I would love to take a look at the log file(s) but I can’t find them and I’m not finding any info in the documentation.

/var/log/lora-pkt-fwd.log

2 Likes

It’s not there:

admin@mtcdt:/var/log# /etc/init.d/ttn-pkt-fwd start
Starting ttn-pkt-fwd: OK
admin@mtcdt:/var/log#
admin@mtcdt:/var/log#
admin@mtcdt:/var/log# ls
app dmesg messages wtmp
boot lastlog mosquitto.log
admin@mtcdt:/var/log#

Sorry, that is different software, this thread is about the multi protocol packet forwarder, not the TTN forwarder. I’m not involved with that software so I can’t advice you.

ok, i apologize then and i will continue my search to the correct packet forwarder. thanks anyways

I cannot get this to work with TTI network server which uses port:1882 not 1883.

Have tried modifying the *_conf.json files “gateway_conf”: …serv_port_up/down etc, to serv_port_up":“1882”. In global/local config files. This doesn’t work, even if I remove the global_conf_src to prevent it overriding the config files.

 tcpdump -AUq port 1883 

Still shows traffic is on 1883 not 1882.

Is there anyway to change the port # without having to compile/make a new package?

The gateway is using the MTAC-LORA-H mCard which is SPI, therefore your @kersing previous legacy packet forwarder wouldn’t work, it works a charm with other gateways. This is AU915 (Australian) config. Tried re-flashing mLinux several times, and tried the Multitech forwarder.

Make sure you use at least r10 of the mp package (available at the installer repo in github) and append the port number to the address like bridge.eu.thethings.network:1882

The older (poly) packet forwarder does not support SPI devices. The SPI devices are a recent addition to the MultiTech line-up. The last build of the old software was created long before the devices became available.