No join accept after join request

Hello everyone

I am trying to connect my end node to theThingsNetwork.
When I send a join request (OTAA), I can see this request on ttn on the data tab for the specific device (also device has last been seen few seconds ago).
However I never get a join accept from the ttn server.

I double checked the app key and if I change it, I don’t even see a join request.
Therefore I assume, the key is correct (I also tried to change big endian to little endian).

My end-node is self built with a RFM95W module from HopeRF.
The LoRaWAN Middleware (v. 1.3.1) from ST/Semtech is based on “LoRaWAN specification 1.0.3” and “LoRaWAN Regional Parameters v1.0.3revA”.
My LoRaWAN MAC-Layer Version is 04.04.02.
I use a dragino DLOS8 outdoor gateway.

Maybe important: when joining with DR_1…5, I don’t see the request on ttn. It only works with DR_0.

What I would like to know from you is, how is it possible to get no join accept when having the right app key, Device EUI and Application EUI?

PS: I know, there are many other posts with very similar questions but most of them don’t get the accept on the device and the guy here only had to recreate a device (I tried that as well).

Thanks for your answers, I really struggle since a longer time now.

The join request:
join_request

What immediately strikes me is the very low RF strength, an RSSI of -138 is very close near the limit and so is an SNR of -19.5. I think you should fix this first before trying other things. The join request may be able to reach the gateway, but then the join accept may not reach the node at this signal level.

So please check your antenna on the node side.
You need an antenna for 868 MHz (assuming you are in Europe), you can’t use a WiFi antenna for example.

Same goes for your gateway, does it receive other nodes with reasonable strength?

2 Likes

In the device data you see the combined request and answer. Only at gateway level you will see two different events.

Looking at your signal level I expect you need to check the antenna connections for the node and the gateway.

1 Like

Thanks a lot for your answers, I really didn’t notice these values are much to low.
I re-plugged the antennas and the values are now slightly better.
But still they are much too low. ( “rssi”: -119, “snr”: -2.2).
The antenna on my end node was given to me without any more information (I assume wrong freq, nothing written on it).
I order a new one and will keep you up to date!

A SNR of -2.2 dB should be ok to establish a connection up to SF7. What is the distance between node and gateway?

1 Like

The distance is three meters and there is no wall in between.
Since the rssi should be between -30 (good) and -120(bad) I expect the antenna to be mismatched.

Under normal circumstances this is much to close. Put the node away from the gateway.

It’s like someone shouting at your ears: you hear him but you don’t understand anything.

1 Like

I removed the device and gateway away (about 30m, including some walls).
Still more or less the same (“rssi”: -126, “snr”: -8.5)

Are you sure that the gateway that is receiving your node is your gateway?

I am, I compared the gateway-ids

So I now have the antenna but this did not make any difference.
Interestingly, the join works with another (similar) board. The snr and rssi are as bad as ever.
I tried it with four boards and only one worked (but only if closer than 10m to the gateway).
The other three had an RX timeout.
I increased the distance to more than 200m but then I had no signal at all.

Does anyone had a similar signal power problem using the RFM95W module?
PS: I tested with a second gateway and the values where the same.

What is the MCU you have wired to the RFM95?
Soldering hiccups happen, can you check continuity on all the pins, particularly DIO1
Which LoRaWAN MAC are you running on your MCU?

1 Like

IIRC, LoRa chips like the sx1276 have several RF outputs, a normal RF output and a “boost” output.
Also, you might have an antenna switch between the antenna and the RF input.
You need to check and make sure what kind of arrangement is present on the RFM95 module.

If the wrong output is selected or if the antenna switch is not driven correctly, I can imagine it works really poorly, with low RSSI/SNR.

Unfortunately, I could not quickly find a schematic of the RFM95 that shows this clearly.

1 Like

Fair chance the radio board is not intended for the frequency being used

2 Likes

Good point, @nicoca, can you post a picture of the underside of the RFM module - the side with the text.

1 Like

I use a STM32L452. The soldering is good, I rechecked with an oscilloscope every signal.
The problem is more that I don’t receive any signal at the RFM95.
My LoRaWAN MAC-Layer Version is 04.04.02.

I thought about that as well but unfortunately I only received the soldered boards.
But I will ask the previous developers.

At this point: Thank you all for your helpful inputs!!

Hi bertrik

I think it was, what you described!
First I found out, a NiceRF module was placed (I thought it is HopeRF).
NiceRF modules (not sure if HopeRF as well, but Semtech do not) use the PA_BOOST output of SX1276, instead of RFO_HF. Setting the PACONFIG register bit 7 to 1 configures the module correctly.

This was a hard piece of work, so thanks for all your ideas!!!
I really like the community in this forum.

PS: rssi is now arround -50 and snr about 10.

3 Likes