No Response from RN module - Arduino UNO + RN2483A

Hi ,

I have just put my Arduino and RN2483A RM105 (868Mhz) LoRa module together as shown here How to build your first TTN node: Arduino + RN2483

Everything works as expected when I am using this library. I was successful in sending my data to the Gateway. But I need to change my frequency from 868 to 865 to 867 (Indian standard)

And that’s when I found this library from Things network seems to have an option to easily change my frequency. So I followed the instructions given here but I just can’t get it to work.

The same hardware works for jpmeijers’s code so I take that I am good with connections. I have also included a software serial and made sure baud rates are fine. When I run the code it says “–PERSONALIZE” and then after some time it says No response from RN Module

What could be the reason? I am ready to provide any more details if required.

Not necessarily. Each library needs to know which serial port to talk to, and the defaults might be different. Did you check the following?

#define loraSerial Serial1
#define debugSerial Serial

(It seems the debugSerial works for you, but what about loraSerial?)

1 Like

[Update] I got it working for the European Frequencies

After comparing both the codes and libraries I notice that jpmeijers’s example code used Arduino D12 pin to reset the RN module but nothing like that was found in the TheThingsNetwork library so I added the below code

  pinMode(12, OUTPUT);
  digitalWrite(12, LOW);
  digitalWrite(12, HIGH);

right after initializing the setup() and before the serial begin lines.

This made the program work and I was able to get the output on the device page. But I tried the same for Indian frequency by changing TTN_FP_EU868 to TTN_FP_IN865_867 and then things dint work.

However, the serial monitor shows everything to be working fine

So I believe this has something to do with my gateway (Liard RG186). So Maybe I should start a separate thread for that