No response of MQTT pub command


I am currently using Dragino’s LPS8N gateway and the LA66 LoRaWAN Shield and trying to use MQTT server to send downlink messages.

MQTT broker address is provided by TheThingsStack. I have checked the subscriber received well when LA66 End Devices sent the uplink message (using AT Commands). Also, I have checked the Join message log sent by the End Device in the subscriber.

The problem is here. I want to publish downlink traffic, but there is no response. The prompt showed me the well-sent log, but there was no response from the subscriber and no log from the console of End Device, gateway. Currently, I’m following the guide provided by TheThingsStack here, “MQTT Server | The Things Stack for LoRaWAN”.

Am I doing wrong? or Should I follow the guide from the manufacturer here(MQTT Forward Instruction - DRAGINO)?

Here is some information about the problem.

  1. Mosquitto -v

  2. Mosquitto_sub

  3. Mosquitto_pub

Thank you in advance for any guidance or advice!

what topic are you sub too

mosquitto_sub -h -t "topic" -u "app1@tenant1" -P "NNSXS.VEEBURF3KR77ZR.." -d

are you sure you command structure se correct
switch are different between up and down

mosquitto_pub -h \
  -t "v3/app1@tenant1/devices/dev1/down/push" \
  -u "app1@tenant1" -P "NNSXS.VEEBURF3KR77ZR.." \
  -m '{"downlinks":[{"f_port": 15,"frm_payload":"vu8=","priority": "NORMAL"}]}' \

Hi, @Piet_Pilay!

I have no idea about ‘switch’, but If I understood correctly about your comment, the problem is the different topics of subscriber and publisher, right? However according to the guide provided by TTS, the use of topic “#” means can subscribe to all topics in a cloud server. I just wanna see all topic messages of subscribers, so I used the “#” topic.

Also, I already have tried to use another specific topic “v3/…/devices/…/down/push”, but it has no response too.

have you tried topic v3/+/devices/+/up or the uplink

for the down do you see anything in the application console