Node-RED quick start guide too out of date


(Smbunn) #1

I wanted to connect my data arriving into TTN using Node-Red. I quickly found the quick start guide.

https://www.thethingsnetwork.org/docs/applications/nodered/quick-start.html#configure

Immediate problem, this guide refers to node-red modules that probably existed two years ago. The latest node red download when you install is node-red-contrib-ttn 2.0.4

It has two new function objects, ttn-event and ttn-uplink. but the quick start mentiond ttn-device and ttn-message so the quick start is no use what so ever.

I am not stupid and have been using AWS IoT gateway with Node-red for some months so thought it cant be that hard.
the new ttn-device asks for:

  • a name
  • an app
  • a device
  • and an event.

These fields do not match anything in the quick start. Is name the device name? I have never seen that asked for ever before. MY devise is called Simon’s FiPy, do I enter that?

An app? Is this the App key, makes the most sense, but what format is it?
2BC47F1E6A4B5E0F7D817BF7C3EB229D
{ 0x2B, 0xC4, 0x7F, 0x1E, 0x6A, 0x4B, 0x5E, 0x0F, 0x7D, 0x81, 0x7B, 0xF7, 0xC3, 0xEB, 0x22, 0x9D } (MSB)?
{ 0x9D, 0x22, 0xEB, 0xC3, 0xF7, 0x7B, 0x81, 0x7D, 0x0F, 0x5E, 0x4B, 0x6A, 0x1E, 0x7F, 0xC4, 0x2B } LSB?

Then a device?
Is this the Device EUI or the Device Address (0x26061522)?

Then event? What is this? Or is this a topic?

How did the quick start get out of alignment with the Node-red?

help please


(Batigolle) #2

Hi @smbunn
here is an example of configuration of the TTN_UPLINK node
My example node flow …
image
how config TTN_UPLINK : first TAB
image
how config TTN_UPLINK : second TAB
image

I hope they help you


Node-RED TTN for grabbing event data not showing information
(Smbunn) #3

Thanks for the message but you must have a completely different TTN for Node Red than I have. I am using 2.0.4.

When I grab a TTN Uplink it looks quite different and none of the fields are editable. Doesn’t matter what I type or where, nothing sticks. My first tab looks like this. No mention of an App Key or a Discovery address.

TTN1

Clicking on any pencil button takes me to this, and I can enter text but hitting “add” just loses everything.

TTN2


(Batigolle) #4

Hi @smbunn
I also have version 2.04
in my previous answer, I only reversed Second TAB with First TAB , sorry
reverse Second TAB with First TAB and vice versa

I left the field “Field” empty


(Smbunn) #5

Thanks, all working now on my secondary computer. There were two problems, the biggest being that the TTN for Node red will not install unless GIT is installed and in the path. On a machine running Node-Red as a service you get no log files as logging goes to console and there is no console. I found this by stopping the service and starting node-red from a console and then uninstalling and re-installing node-red-contrib-TTN.
Now I have the problem that on my main machine I have a corrupted node-red TTN install and it will not let me uninstall it. I might have to fully rebuild the whole machine as I cannot even uninstall node-red from NPM.
Oh the joys of Linux and freeware.


(Marco Benini) #6

In a machine running an SO based on Linux kernel the Node-RED, when run as service, the “console output” can be found in the system log files (syslog , system.log, … it depends on what distribution one is using, service system used, … ).

How did You installed Node-RED? Have You tried to uninstall as root or using sudo ?

p.s.: Node-RED is not freeware, is opensource.


(Batigolle) #7

Hi all
For any problem on NODE-RED,
I report you the "Official Node-Red Forum "
where to report problems and find answers to problems
https://groups.google.com/forum/#!forum/node-red


(Smbunn) #8

I did a complete uninstall including node.js and npm, then complete re-install and it all worked again


(Smbunn) #9

My main computer I just cannot get ttn to work with node-red. I have installed and uninstalled a dozen times, each time it claims success. But none of the TTN Uplink fields are editable.
This is the original problem I had, but this time I have started with a completely fresh machine have loaded the latest versions and have
Node-RED version: v0.18.7
Node.js version: v10.2.1
Linux 4.13.0-1017-gcp x64 LE
node 10.2.1
npm 3.10.10

Any ideas as I have dropped my AWS account to use TTN and now cannot get TTN to connect in Node-Red

Basically the dialogue boxes are like my post above from May 11. I cannot edit any field


(Smbunn) #10

I am working around this by making changes to the TTN connector on my working machine, exporting this to the clipboard and importing on the computer that does not work. I get a red triangle on the object, but it works just fine. No idea why I cannot edit directly.
image


(Bradzcave) #11

worked like a charm, even without any radios going, just testing node-red and ttn configuration. very useful testing tool in the ttn dashboard, well done.

ttn-node-red-no-radios