Node take a long time about 4 o 5 minutos show data on application ttn

I have mounted a minigateway and a node with TTGO ESP32 oled lora v2

when i receive the ttn application data it takes a long time about 4 or 5 minutes.

I also don’t receive the payload “hello world” in my application. I receive code in hexadecimal

why take it long time to receive data on the applicacion of the device?


the code of my applicacion ttn-abp =>


you have a single channel gateway ?
if I look at your screenshot one in every 8 packets is received.
So what you can do is edit the ttn-abp file so you use only one channel, the same one as your gateway is listening

1 Like

Thank for you reply BoRRoZ

In my file ttn-abp I have put it as #define SINGLE_CHANNEL 1
include <lmic.h>
#include <hal/hal.h>
#include <SPI.h>
#include <U8x8lib.h>
#define BUILTIN_LED 25
#define SINGLE_CHANNEL 1 // Set to 1 to force single channel

But in the file gateway I don’t have put SINGLE_CHANNEL 1. I will have to put it.


Such gateway is already single channel. In the sw there is a flag for strict 1ch behaviour but is related to downlinks .
The node is the issue: it sends on 8 different channels. I do not know the effect of the SINGLE_CHANNEL flag: in the code seems not used. If you are in EU, you may simply disable 7 of the 8 channels used:

//disable other channels - for single gateway