Only data packets with some frequencies reach the application console

I have built a number of Arduino-based nodes in the past which mostly work quite reliably.
In recent days I have tried to register new nodes of the same design and with the same code, only the identification codes (EUI’s) were changed. Very surprisingly, the data sent by these latest nodes, although reaching the gateway, become visible on the respective application console only at very irregular intervals.
The nodes were registered with the ABP modality, but the described problem is not related to issues of frame-counting (I have implemented a frame counter in the Arduino code).
After spending a good number of hours trying to analyze the problem I have found out that the data packets of the recently added nodes which reach their destination belong all to one of the sub-frequencies 868100, 868300 or 868500, whereas the packets sent by the nodes with the frequencies 867100, 867300, 867500 or 867700 reach the gateway, but are not forwarded to the application.
Of course all the mentioned frequencies were properly set under advanced MAC settings when registering the new nodes.
I’m quite at a loss about the fact that this problem only affects the recently added nodes and not those already in use for a longer period. Could the problem be related to the recent updates of the Things Network?

Did you add those frequencies before the first uplink? If not try to reset the session and check again.

1 Like

yes, all frequencies were set before the first uplink and I also tried to reset everything, including frame counter, a couple of times, but there was no effect.