OTAA join issue - Australia


(Tuftec) #1

Hi,
I ran into an unxpected problem yesterday when trying to join to a Things Gateway in Australia.
I have one node (RAK811 based) that will connect quite happily with both my RAK831 and Things Gateways. I have another node (LoPy4 based) that will only connect (OTAA) to my RAK gateway. However if the 2 gateways are in close proximity, this node will communicate with both gateways (but only register via RAK).

I have noticed that both nodes use different parameters when trying to connect. Both appear to obey the LoRaWAN specifications for Australia.

The RAK811 uses OTAA, channel 918.2, SF12, BW125.
The LoPy4 uses OTAA, channel 917.5 SF8, BW500.

The RAK831 gateway accepts both activation requests. The Things Gateway does not appear to accept the activation request from the LoPy4 device.

Is this normal behaivour? Is there an update for the Things Gateway to make it compliant with the AU915 requirements for OTAA so that any compliant node will connect?

Extract of LoRaWAN regional parameters:

If using the over-the-air activation procedure, the end-device should broadcast the Join request message alternatively on a random 125 kHz channel amongst the 64 channels defined using DR0 and a random 500 kHz channel amongst the 8 channels defined using DR6.

Thanks in advance.

Peter.


(Tuftec) #2

Bump!!!

Can anyone help with this?

Peter.